Last Comment Bug 702555 - debug method PrintImageDecoders() in imgLoader should be removed (Doesn't work and is confusing)
: debug method PrintImageDecoders() in imgLoader should be removed (Doesn't wor...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 02:51 PST by James May [:fowl]
Modified: 2012-08-23 19:18 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove confusing dead code implying that image decoders are pluggable. (1.55 KB, patch)
2012-08-23 07:02 PDT, James May [:fowl]
justin.lebar+bug: review+
Details | Diff | Splinter Review

Description James May [:fowl] 2011-11-15 02:51:20 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111114 Firefox/11.0a1
Build ID: 20111114031820

Steps to reproduce:

http://hg.mozilla.org/mozilla-central/file/9ae1d4f44b8b/image/src/imgLoader.cpp#l108

While playing around with writing a toy image decoder (in js) this code kept showing up in searches and confusing me.  It's been horribly broken since bug 513681 and it's been there since pre-hg.
Comment 1 James May [:fowl] 2012-08-23 07:02:06 PDT
Created attachment 654600 [details] [diff] [review]
Remove confusing dead code implying that image decoders are pluggable.

This is trivial really, but I did build and run it on my machine anyway. 

I used getReviewer.py to find a reviewer, so if it's not you apologies but I'm just following the instructions :P
Comment 2 Justin Lebar (not reading bugmail) 2012-08-23 11:18:27 PDT
> I used getReviewer.py to find a reviewer, so if it's not you apologies but I'm just 
> following the instructions :P

I'm a fine reviewer for this code.  But also, choosing a poor reviewer is not a faux pas; the reviewer should redirect your request towards someone else without complaint.  :)

Thanks for the patch!
Comment 3 Justin Lebar (not reading bugmail) 2012-08-23 11:41:47 PDT
Normally we'd ask for a patch formatted for checkin-needed [1] before pushing, but since this is your first one, I've added that info and pushed:

  https://hg.mozilla.org/integration/mozilla-inbound/rev/16e1ff49a6a5

Thanks again for the patch!

[1] http://blog.bonardo.net/2010/06/22/so-youre-about-to-use-checkin-needed
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-23 19:18:43 PDT
https://hg.mozilla.org/mozilla-central/rev/16e1ff49a6a5

Note You need to log in before you can comment on or make changes to this bug.