Pausing a video after it's ended doesn't keep it in a paused state.

RESOLVED DUPLICATE of bug 686942

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 686942
7 years ago
7 years ago

People

(Reporter: Mattias, Unassigned)

Tracking

7 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

This statement will make the video will play the video from the start:

//videoElement.ended == true
videoElement.pause();
videoElement.currentTime = 0;

While this statement will keep it paused on the first frame:

//videoElement.ended == true
videoElement.currentTime = 0;
videoElement.pause();



Actual results:

Video was playing.


Expected results:

Video should be paused on the first frame.
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686942
Duplicate of this bug: 544542
You need to log in before you can comment on or make changes to this bug.