Closed Bug 702586 Opened 8 years ago Closed 8 years ago

[ACR Extension] Update ACR compatibility for SeaMonkey (current trunk = 2.8a1)


( Graveyard :: Compatibility Tools, defect, P2)



(Not tracked)



(Reporter: InvisibleSmiley, Assigned: kinger)

Details shows current max SeaMonkey compatibility as 2.7a1. Current trunk is 2.8a1. Please update.

Alternatively, add/set Toolkit 11 compatibility in install.rdf (cf. bug 671399). AFAIK this cannot be done through AMO yet, though.
Version: unspecified → ACR-0.9
Assignee: nobody →
Priority: -- → P2
Target Milestone: --- → ACR-1.0
Fixed, r97766.

(QA : will be in test builds 0.9.6 and greater)
Closed: 8 years ago
Resolution: --- → FIXED
I have to admit that I'm not fully aware of what your internal requirements and procedures are, but from my POV you'd simply have to log into and change the max version for SeaMonkey to 2.8a1. Is this something you can do additionally or, if not, what are the reasons?

In comparison, the SeaMonkey Council (which I am a member of) can directly change the max version for certain other add-ons, especially the ones that SeaMonkey comes bundled with by default (ChatZilla, DOM Inspector and Venkman the JavaScript Debugger), on If your policy permitted to give the SeaMonkey Council user/account access to the ACR entry on AMO we could update the SeaMonkey compatibility ourselves (and we would of course not make any other change at all, let alone upload new files). I'd understand if you'd not want to give control over this out of your hands, though. It's just a suggestion.
That is not the full fix. The code sets prefs to turn off compatibility. However, it is a nightly, and those with it installed will have the nightly pref set already, so I updated the maxVer of version 0.9.3 on AMO to 2.8a1
(In reply to Brian King (Briks) [:kinger] from comment #1)
> Fixed, r97766.
> (QA : will be in test builds 0.9.6 and greater)

Mozilla/5.0 (X11; Linux x86_64; rv:11.0a1) Gecko/20111122 Firefox/11.0a1 SeaMonkey/2.8a1 ID:20111122150138

ACR 1.0 indeed does not display the "incompatible with Sm 2.8a1" warning in about:addons => VERIFIED.
Product: → Graveyard
You need to log in before you can comment on or make changes to this bug.