Last Comment Bug 702627 - Flash: queue invalidation after async surface request
: Flash: queue invalidation after async surface request
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 07:35 PST by James Willcox (:snorp) (jwillcox@mozilla.com)
Modified: 2012-01-09 15:01 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Invalidate plugin rect after requesting Java surface during paint (2.02 KB, patch)
2011-11-15 07:37 PST, James Willcox (:snorp) (jwillcox@mozilla.com)
no flags Details | Diff | Splinter Review
Invalidate plugin rect after requesting Java surface during paint (2.02 KB, patch)
2011-11-15 07:37 PST, James Willcox (:snorp) (jwillcox@mozilla.com)
blassey.bugs: review+
Details | Diff | Splinter Review

Description James Willcox (:snorp) (jwillcox@mozilla.com) 2011-11-15 07:35:20 PST
With the patch to Bug 702334 applied, we asynchronously request the Java plugin surface during paint (if required). We should invalidate the whole rect in this case since the current paint failed.
Comment 1 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-11-15 07:37:05 PST
Created attachment 574595 [details] [diff] [review]
Invalidate plugin rect after requesting Java surface during paint
Comment 2 James Willcox (:snorp) (jwillcox@mozilla.com) 2011-11-15 07:37:53 PST
Created attachment 574596 [details] [diff] [review]
Invalidate plugin rect after requesting Java surface during paint
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-16 06:38:07 PST
https://hg.mozilla.org/projects/birch/rev/8d659ca1ae0e

Note You need to log in before you can comment on or make changes to this bug.