Kill excludeItemsIfParentHasAnnotation query option

RESOLVED FIXED in mozilla13

Status

()

Toolkit
Places
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

(Blocks: 2 bugs, {addon-compat, dev-doc-complete, perf})

Trunk
mozilla13
addon-compat, dev-doc-complete, perf
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
This existed mostly for livemarks, it's complex and should just die for now.
(Assignee)

Comment 1

6 years ago
I think I may be able to remove another rock from FilterResultSet, and that would be another step towards async queries, let's see what I'll end up with.
Assignee: nobody → mak77
Status: NEW → ASSIGNED
(Assignee)

Comment 2

6 years ago
Created attachment 578053 [details] [diff] [review]
patch v1.0

So, the last vestiges of FilterResultSet() exist just to remove duplicate uris from tags and check if a node can be added to a query with search terms.
The former will be fixable changing tags schema, the latter is not a bug, once the former is fixed FilterResultSet can be merged into EvaluateQueryForNode (or become an helper like EvaluateSearchTermsForNode).
I wonder if I could subquery tags, so that the external query removes duplicates and completely kill FilterResultSet() now, would be fancy.
(Assignee)

Comment 3

6 years ago
Comment on attachment 578053 [details] [diff] [review]
patch v1.0

note that this depends on the livemarks changes, so it can't land before.
Attachment #578053 - Flags: review?(dietrich)
(Assignee)

Comment 4

6 years ago
Comment on attachment 578053 [details] [diff] [review]
patch v1.0

Review of attachment 578053 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/components/places/nsNavHistory.cpp
@@ +4137,5 @@
>            .Str(", h.url, page_title, tags, ")
>            .Str(nsPrintfCString(17, "0, 0, 0, 0, %d, 0)",
>                                 mozIPlacesAutoComplete::MATCH_ANYWHERE_UNMODIFIED).get());
> +    // Serching by terms implicitly exclude queries.
> +    clause.Condition("NOT url BETWEEN 'place:' AND 'place;'");

self-comment: should be h.url
(Assignee)

Updated

6 years ago
Blocks: 386396
Comment on attachment 578053 [details] [diff] [review]
patch v1.0

Review of attachment 578053 [details] [diff] [review]:
-----------------------------------------------------------------

looks ok, r=me
Attachment #578053 - Flags: review?(dietrich) → review+
(Assignee)

Updated

5 years ago
Blocks: 490714
(Assignee)

Comment 6

5 years ago
Created attachment 596000 [details] [diff] [review]
patch v1.1

fixes a subtle bug with excludeQueries that was failing a test on Try.
Attachment #578053 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Whiteboard: [needs SR]
(Assignee)

Comment 7

5 years ago
Comment on attachment 596000 [details] [diff] [review]
patch v1.1

Review of attachment 596000 [details] [diff] [review]:
-----------------------------------------------------------------

oops, I forgot I still need a SR here :)

This options was useful only to filter out livemark children from queries, now that load-on-demand livemarks exist it is no more useful.
The reason we can't just deprecate it is that its removal allows to speed up quite some queries, on the other side the places query strings just ignore unknown options, and this will just become one of those, so compatibility issues should be limited.
Attachment #596000 - Flags: superreview?(gavin.sharp)
Attachment #596000 - Flags: superreview?(gavin.sharp) → superreview+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/51830afab77b
Whiteboard: [needs SR]
Target Milestone: --- → mozilla13
(Assignee)

Comment 9

5 years ago
I don't expect any interesting breakage from this, btw adding the keyword.
Keywords: addon-compat
(Assignee)

Comment 10

5 years ago
and documentation may have some pointer to this
Keywords: dev-doc-needed
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/mozilla-central/rev/51830afab77b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Depends on: 736541
Blocks: 743677
Docs updated:

https://developer.mozilla.org/en/Places_query_URIs#Query_operators
https://developer.mozilla.org/en/XPCOM_Interface_Reference/nsINavHistoryQueryOptions#Attributes

Mentioned on Firefox 13 for developers.
Keywords: dev-doc-needed → dev-doc-complete
Depends on: 793523
You need to log in before you can comment on or make changes to this bug.