Last Comment Bug 702753 - implement "make install" for android
: implement "make install" for android
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 702486
  Show dependency treegraph
 
Reported: 2011-11-15 13:38 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2011-11-16 06:37 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (758 bytes, patch)
2011-11-15 13:38 PST, Brad Lassey [:blassey] (use needinfo?)
doug.turner: review+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-11-15 13:38:23 PST
Created attachment 574675 [details] [diff] [review]
patch

wasted time today because we bumped the version number, this will hopefully avoid that in the future
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-15 13:41:56 PST
Comment on attachment 574675 [details] [diff] [review]
patch

This is kinda brittle, since it assumes adb and a single device. I mean it's not that useful in a general sense. Should it be in the tree?
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-11-15 14:12:57 PST
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Comment on attachment 574675 [details] [diff] [review] [diff] [details] [review]
> patch
> 
> This is kinda brittle, since it assumes adb and a single device. I mean it's
> not that useful in a general sense. Should it be in the tree?

using device manager may be better impl, but I figure this is the base case. Happy to file a follow up bug to do better.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-15 17:03:10 PST
Why does this block bug 702829 ?
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2011-11-15 17:08:20 PST
I assume because Naoki created bug 702829 as a clone of bug 702486
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-16 06:37:43 PST
Brad landed https://hg.mozilla.org/projects/birch/rev/bcada4117c30

Ifixed some bustage https://hg.mozilla.org/projects/birch/rev/452d17984010

Note You need to log in before you can comment on or make changes to this bug.