Last Comment Bug 702764 - Library loading times need to be adjusted on birch
: Library loading times need to be adjusted on birch
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla11
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 13:44 PST by (dormant account)
Modified: 2012-02-01 13:59 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
part 1 - Use RUSAGE_THREAD for library loading time consumption reporting (2.51 KB, patch)
2011-11-16 09:49 PST, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review
part 2 - Make nsAppStartup::GetStartupInfo more flexible (20.20 KB, patch)
2011-11-17 10:37 PST, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review
part 3 - Add linker initialization and library loading timestamps for nsAppStartup::GetStartupInfo (3.72 KB, patch)
2011-11-17 10:38 PST, Mike Hommey [:glandium]
taras.mozilla: review+
Details | Diff | Splinter Review

Description (dormant account) 2011-11-15 13:44:11 PST
We should use RUSAGE_THREAD in getrusage. This will allow us to capture cpu time spent on library loading and compare it to overall cpu time.
Comment 1 Mike Hommey [:glandium] 2011-11-15 14:27:07 PST
Why birch only?
Comment 2 (dormant account) 2011-11-15 14:32:15 PST
(In reply to Mike Hommey [:glandium] from comment #1)
> Why birch only?

birch is my justification. This should happen on mc too.
Comment 3 (dormant account) 2011-11-15 14:34:23 PST
Note we also need another metric to see how long the process was alive before we started loading libraries, this will notify us of lag introduced by native ui.
Comment 4 Doug Turner (:dougt) 2011-11-15 15:01:50 PST
put it on m-c.  we can merge it in.
Comment 5 Mike Hommey [:glandium] 2011-11-16 09:49:19 PST
Created attachment 574921 [details] [diff] [review]
part 1 - Use RUSAGE_THREAD for library loading time consumption reporting
Comment 6 Mike Hommey [:glandium] 2011-11-17 10:37:12 PST
Created attachment 575222 [details] [diff] [review]
part 2 - Make nsAppStartup::GetStartupInfo more flexible
Comment 7 Mike Hommey [:glandium] 2011-11-17 10:38:31 PST
Created attachment 575225 [details] [diff] [review]
part 3 - Add linker initialization and library loading timestamps for nsAppStartup::GetStartupInfo

Pushed to try:
https://tbpl.mozilla.org/?noignore=1&tree=Try&rev=d21392a69d35
Comment 8 Mike Hommey [:glandium] 2011-11-17 10:48:13 PST
Another try that doesn't fail due to the switch to mobile/xul tree:
https://tbpl.mozilla.org/?noignore=1&tree=Try&rev=09e355059af0
Comment 9 (dormant account) 2011-11-17 15:53:21 PST
Comment on attachment 575222 [details] [diff] [review]
part 2 - Make nsAppStartup::GetStartupInfo more flexible

RecordOnce is more expensive, but I understand why you do it

Note You need to log in before you can comment on or make changes to this bug.