Last Comment Bug 702776 - Missing margin in the highlighter and web console buttons
: Missing margin in the highlighter and web console buttons
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: Firefox 11
Assigned To: Sonny Piers [:sonny]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 14:21 PST by Sonny Piers [:sonny]
Modified: 2011-11-17 18:08 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
highlighter buttons (11.68 KB, image/png)
2011-11-16 01:40 PST, Paul Rouget [:paul]
no flags Details
console buttons (9.24 KB, image/png)
2011-11-16 01:40 PST, Paul Rouget [:paul]
no flags Details
patch v1 (2.59 KB, patch)
2011-11-16 05:53 PST, Sonny Piers [:sonny]
mihai.sucan: review+
dao+bmo: review+
Details | Diff | Review

Description Sonny Piers [:sonny] 2011-11-15 14:21:33 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111106170155
Comment 1 Paul Rouget [:paul] 2011-11-16 01:40:33 PST
Created attachment 574847 [details]
highlighter buttons
Comment 2 Paul Rouget [:paul] 2011-11-16 01:40:55 PST
Created attachment 574848 [details]
console buttons
Comment 3 Sonny Piers [:sonny] 2011-11-16 05:53:12 PST
Created attachment 574888 [details] [diff] [review]
patch v1

This makes all toolbarbuttons on linux 3px margins on left/right.
Comment 4 Sonny Piers [:sonny] 2011-11-16 05:57:17 PST
(on devtools)
Comment 5 Paul Rouget [:paul] 2011-11-16 06:28:18 PST
Usually, on Linux, toolbar-buttons don't need margins. The separation is done with the padding. But it doesn't look good if the buttons have borders (like the highlighter and the web console).

That's why we need this patch.
Comment 6 Mihai Sucan [:msucan] 2011-11-16 07:37:42 PST
Comment on attachment 574888 [details] [diff] [review]
patch v1

Review of attachment 574888 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good! Thank you very much for your contribution Sonny! r+!
Comment 7 Paul Rouget [:paul] 2011-11-17 03:22:15 PST
This doesn't pass all the tests:

INFO | runtests.py | Running tests: end.
mochitest-browser-chrome failed:
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box width matches dimensions of element (no zoom) - Got 0, expected 22
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box height matches dimensions of element (no zoom) - Got 0, expected 22
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box width matches width of element (2x zoom) - Got 947, expected 44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_highlighter.js | transparent veil box height matches width of element (2x zoom) - Got 154, expected 44
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_iframeTest.js | selection matches div2 node - Got [object HTMLDivElement], expected [object HTMLDivElement]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/highlighter/test/browser_inspector_iframeTest.js | highlighter matches selection - Got [object HTMLDivElement], expected [object HTMLDivElement]

This is interesting because we have the same problem with bug 700333
Comment 8 Rob Campbell [:rc] (:robcee) 2011-11-17 09:25:49 PST
https://hg.mozilla.org/integration/fx-team/rev/9f68a7bd5abe

in fx-team. Thanks for the patch, sonny!
Comment 9 Blair McBride [:Unfocused] (mostly unavailable, needinfo open, reviews not) 2011-11-17 18:05:00 PST
https://hg.mozilla.org/mozilla-central/rev/9f68a7bd5abe

Note You need to log in before you can comment on or make changes to this bug.