Default theme issue with default Ubuntu theme (Ambiance)

RESOLVED DUPLICATE of bug 644169

Status

Thunderbird
Theme
--
minor
RESOLVED DUPLICATE of bug 644169
6 years ago
6 years ago

People

(Reporter: pqwoerituytrueiwoq, Unassigned)

Tracking

8 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround: comment #4])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 574702 [details]
Visual description of theme issue

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0) Gecko/20100101 Firefox/7.0
Build ID: 20110922234819

Steps to reproduce:

Updated to Thunderbird 8 from Thunderbird 7/Thunderbird 7.0.1 via the Thunderbird stable ppa (mozilla team)
open and saw the theme mistake/error/bug


Actual results:

Updated successfully and 1st thing i saw was a theme issue


Expected results:

the toolbars should look like they do in every other application on the system there was no theme issues in Thunderbird 7

Only the menu bar should have the dark background the rest of the toolbars should have the normal background/design

I have found this issue on ubuntu 10.04 and linux mint 11 with the system theme ambiance
Thanks for your bug report!
That look is by design, but will go away once bug 644169 is fixed.
(Reporter)

Comment 2

6 years ago
Ok votes for that bug to be fixed
At least I managed to fix it with the userChrome.css file do you know if there is a color variable like there is the -moz-dialog color i can use instead of the manual colors I used


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
.chromeclass-toolbar, .tabs-stack{
	-moz-appearance:toolbar!important;
}
.chromeclass-toolbar .toolbarbutton-text,tab[afterselected="true"] .tab-text,.chromeclass-toolbar toolbaritem > label{
	color:#4C4C4C!important;
}
.chromeclass-toolbar toolbarbutton[disabled="true"] .toolbarbutton-text{
	color:#9c9ca2!important;
}
Here is a list of available colors:
https://developer.mozilla.org/en/CSS/color_value#System_Colors

Is -moz-DialogText and ButtonText what you're looking for perhaps?
(Reporter)

Comment 4

6 years ago
Thanks *bookmarks*
I don't see why you need to wait on bug 644169 since I could do it with this code

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
.chromeclass-toolbar{
	-moz-appearance:toolbar!important;
}
.tabmail-tabs{
	-moz-appearance:statusbar!important;
	background-color:-moz-dialog!important;
}
.chromeclass-toolbar .toolbarbutton-text,tab[afterselected="true"] .tab-text,tab[beforeselected="true"] .tab-text{
	color:ButtonText!important;
}
.chromeclass-toolbar toolbaritem > label{
	color:WindowText!important;
}
.chromeclass-toolbar toolbarbutton[disabled="true"] .toolbarbutton-text{
	color:GrayText!important;
}

Comment 5

6 years ago
The current styling may still apply if the user chooses to keep the tabs below the toolbar as in the current releases (assuming that bug 644169 follows the Firefox implementation of bug 544815 to provide such an option to the user).
(In reply to pqwoerituytrueiwoq from comment #4)
> Thanks *bookmarks*
> I don't see why you need to wait on bug 644169 since I could do it with this code

As far as I know, the patch in 644169 is ready to land for next stable release, so no need to fix it in a separate bug. Therefore I'm marking this as bug as Duplicate.
Thanks again for your bug report, and let me know if you run into this issue after bug 644169 is fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644169
(In reply to rsx11m from comment #5)
> The current styling may still apply if the user chooses to keep the tabs
> below the toolbar as in the current releases (assuming that bug 644169
> follows the Firefox implementation of bug 544815 to provide such an option
> to the user).

It will not allow such option (could be done as addon, but in that case the addon would need to provide that styling).
(Reporter)

Comment 8

6 years ago
i think there is a better word for this than DUPLICATE (maybe dependency w/ no work needed) but it does not matter since that is not a category at least i have a patch for it for the next few weeks i am a perfectionist
you are saying tabs on top/bottom will not be a option in Thunderbird 9 and they will be on top?

Comment 9

6 years ago
Yeah, this probably should have left open and resolved "works for me" once the other bug has landed and the issue is no longer observed, but anyway.

> you are saying tabs on top/bottom will not be a option in Thunderbird 9
> and they will be on top?

That's what bug 644169 comment #67 says, tabs on top will be mandatory with Thunderbird 11 (I'd assume, don't think this is beta or even aurora stuff).
Whiteboard: [workaround: comment #4]
(Reporter)

Comment 10

6 years ago
if tabs on top will be mandatory that may suck but if everything opens in tabs (would love that) it may be better (and make tabs on bottom less piratical since the buttons would change from tab to tab)
i think there should be a way to add toolbar above the tab bar for the purpose of addon buttons essentially a addon bar (or maybe the bottom like in firefox)

wonder how it will look with lightening since the events column uses space on the tab bar as it is now
(Reporter)

Comment 11

6 years ago
One other thing I forgot to mention speaking of button switching from tab to tab
for the love of god do not make it anything like Microsoft's ribbon **** I can't stand that piece junk that and the start menu layout are to bug reasons why I quick using windows

tabs on bottom is default in Firefox under Linux should we expect something similar in Thunderbird?
(Reporter)

Comment 12

6 years ago
One other thing I forgot to mention speaking of button switching from tab to tab
for the love of god do not make it anything like Microsoft's ribbon **** I can't stand that piece junk that and the start menu layout are to bug reasons why I quit using windows

tabs on bottom is default in Firefox under Linux should we expect something similar in Thunderbird?
(In reply to pqwoerituytrueiwoq from comment #8)
> i think there is a better word for this than DUPLICATE (maybe dependency w/
> no work needed) but it does not matter since that is not a category at least
> i have a patch for it for the next few weeks i am a perfectionist
> you are saying tabs on top/bottom will not be a option in Thunderbird 9 and
> they will be on top?


Yeah, I'm no expert on the status flags, so I might have set the wrong flag. My thinking was that if I set dependency on this bug on the other bug, it would seem like this would have to be fixed before we could land the patch in #644169

A small note regarding black toolbars in general that several Ubuntu toolbars seems to be all black [1] [2], so it seems we're currently consistent with that.

1. http://2.bp.blogspot.com/-nbadwNHLqZ4/Tlk3RoF8unI/AAAAAAAACbs/Bp6gVWeUd7E/s1600/gnome_control_center.png
2. http://lh6.googleusercontent.com/-Ne2Y-8YhYsc/TpGi2QlDatI/AAAAAAAAAd0/ha3C9Il6XJg/s1600/Software-Center-Oneiric-3.png
(In reply to pqwoerituytrueiwoq from comment #12)

> tabs on bottom is default in Firefox under Linux should we expect something
> similar in Thunderbird?

It is? Not on my machines. Are you running an old profile?
Comments specifically about the tabs-on-top feature should probably happen in bug 644169. Doing it in this bug will make it hard to keep track of feedback.
(Reporter)

Comment 15

6 years ago
confiremd, opps i was thinking of the Firefox Button meant to be similar the the menu button on MS office
can these comments be moved the that bug's comments or should they be linked

i think i have been using this profile since maybe firefox 2 assuming i did not have to scrap it i even migrated my profile from windows to linux when i switched

i still think you should use the -moz-appearance:toolbar and not -moz-appearance:menubar like i did above and let the theme decide how to color it
http://i.imgur.com/FkZbO.png
notice how the toolbar is a gradient in gedit and the menu bar is not they are not the save styling code
You need to log in before you can comment on or make changes to this bug.