Last Comment Bug 702903 - IAccessibleRelation::get_target broken
: IAccessibleRelation::get_target broken
Status: RESOLVED FIXED
[qa?]
: access, regression
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All Windows 7
: -- normal (vote)
: mozilla11
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
Depends on:
Blocks: 641838
  Show dependency treegraph
 
Reported: 2011-11-16 01:17 PST by alexander :surkov
Modified: 2012-02-01 13:58 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (850 bytes, patch)
2011-11-16 01:17 PST, alexander :surkov
tbsaunde+mozbugs: review+
christian: approval‑mozilla‑aurora+
christian: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description alexander :surkov 2011-11-16 01:17:25 PST
Created attachment 574843 [details] [diff] [review]
patch

regression from bug 641838
Comment 1 alexander :surkov 2011-11-17 18:45:06 PST
inbound land https://hg.mozilla.org/integration/mozilla-inbound/rev/190255a17276
Comment 2 Ed Morley [:emorley] 2011-11-18 03:02:24 PST
https://hg.mozilla.org/mozilla-central/rev/190255a17276
Comment 3 alexander :surkov 2011-11-20 23:15:06 PST
Comment on attachment 574843 [details] [diff] [review]
patch

broken implementation of major accessibility API what prevents screen readers and other ATs to rely on it. Trivial patch, safe to take.
Comment 4 christian 2011-11-22 10:22:28 PST
Comment on attachment 574843 [details] [diff] [review]
patch

[triage comment]
Approved for aurora and beta. Please land today if at possible.
Comment 5 christian 2011-11-22 17:54:24 PST
Errr, so I tried to transplant this and it already looks to be on beta and aurora...am I missing something? (entirely possible)
Comment 6 christian 2011-11-22 17:57:30 PST
Ah, and I was missing that someone landed it under me :-)

http://hg.mozilla.org/releases/mozilla-aurora/rev/e47a1f1fdfbd
http://hg.mozilla.org/releases/mozilla-beta/rev/a8b9b7d98fb5
Comment 7 David Bolter [:davidb] 2011-11-22 18:03:20 PST
Yeah sorry about that. There's an expectation that we comment all landings but we sometimes forget.
Comment 8 alexander :surkov 2011-11-22 19:09:18 PST
Thank you for landing.

Christian, any chance we can deliver this patch as update to released Firefox 8? What's conditions?
Comment 9 christian 2011-11-22 19:14:26 PST
You need to show impact (pref. with numbers) and also show why this wasn't caught during Nightly, Aurora, or Beta if the impact is large. The bar is very, very high, especially as we are 1/2 way through the cycle towards Fx9.

Basically, we need to trade off the pain/annoyance/egg-on-our-face of a 8.0.2 with waiting a couple more weeks for the fix. Note that this calculation will change somewhat when we have less disruptive updates.
Comment 10 alexander :surkov 2011-11-22 19:49:49 PST
Ok, I see. No known major affected ATs, that's why it was noticed when Firefox 8 was released. This is egg-on-our-face problem but due to fast release cycle impact might be not large.
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-01 14:56:08 PST
Is there something QA can do to verify this fix?
Comment 12 David Bolter [:davidb] 2011-12-15 09:37:24 PST
Quickest route to verifying this is using DOM Inspector, which I'm trying to download to test with FF9 but the download is failing. Will update when I get somewhere.
Comment 13 David Bolter [:davidb] 2011-12-15 09:47:09 PST
OK got it. Verified relations are exposed in FF9. Verification via DOM Inspector "Accessible Tree" view and "Accessible Relations" object view.
Comment 14 David Bolter [:davidb] 2011-12-15 13:05:11 PST
And also confirmed properly with accprobe, the IA2 relations are exposed.

Note You need to log in before you can comment on or make changes to this bug.