Java applet menu items have strange behavior since Java Plugin 1.6.0_29

RESOLVED WONTFIX

Status

()

Core
Plug-ins
P3
normal
RESOLVED WONTFIX
6 years ago
11 months ago

People

(Reporter: Pat Flaherty, Unassigned)

Tracking

({helpwanted})

8 Branch
x86
Mac OS X
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111109112850

Steps to reproduce:

Launched a java applet on MacOSX using either FireFox 8 or 9 and Java Plugin 1.6.0_29.
Goto http://www.rampageremote.com and login with apple as username and apple as the password. Click the "Proof" button to spawn the applet.


Actual results:

When I click on any of the *Applet's* menu items (except File), they all jump over to the File menu item. For this applet click on any of the following menu items and pull down:
-Window
-Admin
-Help
They will all jump over to the File menu item.  (Weird)


Expected results:

The menu items to be selectable as one would expect when selecting a menu item.

This works fine with the same Java Plugin in Safari & Chrome. It seems to have been introduced when the Java Plugin 1.6.0_29 was released.

Updated

6 years ago
Component: Menus → Plug-ins
Product: Firefox → Core
QA Contact: menus → plugins
What version of OS X are you using?  It can't be 10.5.X, because Apple's latest Java updates were only released for OS X 10.6 and 10.7.
(Reporter)

Comment 2

6 years ago
That is correct, not 10.5.x. The affected OS versions are 10.6 and 10.7. Confirmed on both platforms.
I can confirm this.

Your description from comment #0 is pretty vague.  Here's what I see:

1) Open	any menu but the File menu (the	one on the left), by
   left-clicking on it.	 Then let go the mouse.

2) Move	the mouse down to browse the menu.

   When you do this, the current menu closes and the File menu opens.

If you don't let go of the mouse in step 1, you can browse Window
menu.  And (still not letting go of the mouse) I find I can also
browse over from the Window menu to the Admin and Help menus.  But the
current behavior is clearly not correct.

I can reproduce this with FF 8 and today's mozilla-central (trunk)
nightly on OS X 10.6.8 and 10.7.2 with Apple's latest Java updates.  I
can't reproduce it on 10.7.2 with Apple's previous version of Java
(the one that came with 10.7.2).  I also can't reproduce it with FF
7.0.1.

So there may be bugs on both sides -- in FF and in Apple's latest Java
updates.  We should know more once we find the FF regression range --
once we know which mozilla-central nightly these problems started in.

I'll get to this when I can.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → smichaud
(Reporter)

Comment 4

6 years ago
Just another bit of information. If you use the Shift-Command to remove the applet from the browser, it will begin to work.
(Reporter)

Updated

6 years ago
Severity: normal → major
Priority: -- → P1

Comment 5

6 years ago
This bug is weird. I have direct my customer base to Safari or Chrome to get it to work. Any timeframe on a fix ?
(Reporter)

Comment 6

6 years ago
Please someone respond to this. Is this a bug in Firefox or in the Mac Java ?
That was in question when bug was submitted. If it's a bug in Apple's Java I can work with Apple. If it's a bug in Firefox then nobody has told me whether *or not* this will be fixed. If it's not I can handle it. I just need to know. Silence is the worst possible scenario when you have customers that you are trying to answer to.

Thanks for any response.
Pat
I'm not going to be able to get to this anytime soon.  In the meantime I'm afraid you're on your own.

Go ahead and report this to Apple.
Assignee: smichaud → nobody

Comment 8

5 years ago
(In reply to Steven Michaud from comment #7)
> I'm not going to be able to get to this anytime soon.  In the meantime I'm
> afraid you're on your own.
> 
> Go ahead and report this to Apple.

Steven, is there anyway you can spend some time on this bug? There is a duplicate bug (Bug 761084), so it not just me reporting it. Also are you the only one that can fix this or can you suggest a workaround? Oracle now owns Java on the Mac platform as you know and it still an issue in Mac Java 7 & 8. It seems to be Firefox only also.

Even just a bit of your time would be appreciated as it just might be a easy bug to solve.

Thanks
Pat
> Steven, is there anyway you can spend some time on this bug?

I'm afraid not.  My situation hasn't changed in the last year.

But I'd be willing to take another look if you find the regression range for this bug *in mozilla-central nightlies*.
(Reporter)

Comment 10

5 years ago
If not you then who ? Does Mozilla have someone that can take up this bug besides you.
Can you forward it to someone that can take a look at it?
Duplicate of this bug: 761084
Priority: P1 → P3
Bug 761084 had some good details:

A good showcase of the issue: http://www.dreamchain.com/jmenubar-not-working-for-japplet-in-firefox-on-mac/

Bug 761084, comment 4:
> Now, if you look at the behaviour of the same version of Java in Safari 6.0:
> 
> The menu items that the cursor points to are not highlighted, just like with
> Firefox! Pop-out sub menus do not pop out unless clicked on.
> 
> If the mouse cursor ever leaves the popped up menu area, the correct menu
> _stays open_. It remains open unless the mouse cursor leaves the applet area
> and returns to the applet, at which time the first File menu gets popped
> open.
> 
> 
> So the Firefox bug seems to be that the mouse cursor leaving the area of a
> popped-up menu causes the first menu to be opened instead.

Bug 761084, comment 5:
(In reply to Nicholas Sherlock from comment #5)
> This bug does not occur when the applet uses th Nimbus Look&Feel: The mouse
> can leave the popped-up menu and the correct menu stays open. Menu items
> still do not highlight when rolled over, though.
> 
> The same issue does occur on the Metal L&F. So both the Mac Aqua and Metal
> L&F demonstrate this issue, Nimbus does not.

... which would make this likely a Java issue - can someone confirm this regarding themes?
Severity: major → normal
(Reporter)

Comment 13

5 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #12)
> Bug 761084 had some good details:
> 
> A good showcase of the issue:
> http://www.dreamchain.com/jmenubar-not-working-for-japplet-in-firefox-on-mac/
> 
> Bug 761084, comment 4:
> > Now, if you look at the behaviour of the same version of Java in Safari 6.0:
> > 
> > The menu items that the cursor points to are not highlighted, just like with
> > Firefox! Pop-out sub menus do not pop out unless clicked on.
> > 
> > If the mouse cursor ever leaves the popped up menu area, the correct menu
> > _stays open_. It remains open unless the mouse cursor leaves the applet area
> > and returns to the applet, at which time the first File menu gets popped
> > open.
> > 
> > 
> > So the Firefox bug seems to be that the mouse cursor leaving the area of a
> > popped-up menu causes the first menu to be opened instead.
> 
> Bug 761084, comment 5:
> (In reply to Nicholas Sherlock from comment #5)
> > This bug does not occur when the applet uses th Nimbus Look&Feel: The mouse
> > can leave the popped-up menu and the correct menu stays open. Menu items
> > still do not highlight when rolled over, though.
> > 
> > The same issue does occur on the Metal L&F. So both the Mac Aqua and Metal
> > L&F demonstrate this issue, Nimbus does not.
> 
> ... which would make this likely a Java issue - can someone confirm this
> regarding themes?

This happens with all 3 themes for me. Bug is almost 2 years old. People have move away from Firefox as a workaround which is reasonable although Mozilla's response so far has been terrible.
Having a regression range to look at is still the best path here. We have a tool for that that makes finding it easy:
http://mozilla.github.io/mozregression/
Keywords: helpwanted, qawanted, regressionwindow-wanted
(Reporter)

Comment 15

5 years ago
If it's that easy why don't you guys do it? 2 year old bug that was ignored with many
people impacted. No, Safari, is the answer here.
There seems to be a general Mac problem with these JMenus, both in Safari and FF - "The menu items that the cursor points to are not highlighted", as said in https://bugzilla.mozilla.org/show_bug.cgi?id=761084#c4

(In reply to Georg Fritzsche [:gfritzsche] from comment #12)
> A good showcase of the issue:
> http://www.dreamchain.com/jmenubar-not-working-for-japplet-in-firefox-on-mac/
I couldn't reproduce this on Mac OS X 10.7.5, Java 7u25. With other words I don't see differences between FF 4 and FF 20.

The only issue I found is: http://img401.imageshack.us/img401/1659/uykq.png --the File/Edit menus are displayed in the top left of the screen
Last good nightly: 2012-12-22
First bad nightly: 2012-12-23

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bf26f61a0748&tochange=84320dffec6e
Keywords: qawanted, regressionwindow-wanted
Pat, what are your actual results on http://dreamchain.com/static/applet-with-menubar.html using latest java 7u25 and firefox nightly http://nightly.mozilla.org/ ?
Flags: needinfo?(pflahrty)
(In reply to Paul Silaghi [QA] from comment #16)
> The only issue I found is: http://img401.imageshack.us/img401/1659/uykq.png
> --the File/Edit menus are displayed in the top left of the screen

That is a known issue with Java calling NPN_ConvertPoint() off-main-thread (made noticeable by bug 823559, which is in that pushlog).
(Reporter)

Comment 19

5 years ago
(In reply to Paul Silaghi [QA] from comment #17)
> Pat, what are your actual results on
> http://dreamchain.com/static/applet-with-menubar.html using latest java 7u25
> and firefox nightly http://nightly.mozilla.org/ ?

I get what Georg describes above, where now the whole menu list jumps to the top of the screen. I went back to Java 6 with the nightly build and the behavior was as I described in my original bug. https://bugzilla.mozilla.org/show_bug.cgi?id=703007 (This bug thread we are on) That Java 6 behavior was :

1) Open	any menu but the File menu (the	one on the left), by
   left-clicking on it.	 Then let go the mouse.

2) Move	the mouse down to browse the menu.

   When you do this, the current menu closes and the File menu opens.
So, with nightly build, both Java 6 & 7 have problems with menu items but the behavior displayed between the 2 is different.
Flags: needinfo?(pflahrty)
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.