Attaching signature makes Mozilla crash when pressing new message button

VERIFIED FIXED

Status

MailNews Core
Composition
--
major
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: nikolai, Assigned: Jean-Francois Ducarroz)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If a signature is attached, Mozilla crashes when I want to compose new message.
Set to compose in plain-text. Tried different signatures.
Happens in 26. and 23. feb builds. Did not try it in other builds.
Works ok, if I remove signature setting.

Comment 1

17 years ago
Reporter do you have the talkback ID's of the crashs?
Keywords: crash
(Reporter)

Comment 2

17 years ago
Instruct me how to get that talkback ID.
But I do not know if talkback is installed in the the nightlies.
I use the mozilla-installer.exe.
If not, please instruct me how to manual install talkback into my current
installation.
(Assignee)

Comment 3

17 years ago
maybe it's a dup of bug 70500, can you try again with tomorrow's build (03/02)?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
Yep, bug still there.
(Assignee)

Comment 5

17 years ago
Can you attach a signature file that cause the crash on this bug report. Thanks
(Reporter)

Comment 6

17 years ago
It doesn't matter which signature file I attach, the bug is always there. Also
no matter if it is UNIX or DOS linebreaks.
BUT, I just discovered something new. If I go back into the mail settings, the
field which should hold the filename has become empty!!?! It happens every time
I close the settings and reopens it, the field becomes empty! But the checkbox
is still checked though, and when it is checked Mozilla crashes just after the
'compose new message' window pops up.

Comment 7

17 years ago
In fact, the path of the signature file is never saved at all: I just installed
a recent build (2001-03-02-20) over a previous one which did not have this
problem and my signature file is still there. I try to change it to something
else and the next time I call the dialog, the old path is still there! If I
perform a clean install then no signature path is ever saved in the preferences.

Comment 8

17 years ago
What is the path to your signature file?  Does it contain any non-ascii 
characters?  Just wondering if the path may have anything to do with this crash.

The part about the changes not sticking is covered under bug 
http://bugzilla.mozilla.org/show_bug.cgi?id=70641

Comment 9

17 years ago
It seems to me that the path itself has nothing to do with this bug (and bug
70641 as well). I have tried signature files as simple as "E:\sig.txt" with no luck.

Comment 10

17 years ago
This bug seems fixed in 2001-03-27-20 / Win98. Maybe it was just a duplicate of
bug 70641. I have even tried signature files with greek characters in the pathname.
(Reporter)

Comment 11

17 years ago
Ya, it's fixed. Cool.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 12

17 years ago
verified fixed.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.