Dragging shortcuts to browser windows no longer works

VERIFIED DUPLICATE of bug 76728

Status

()

Core
Drag and Drop
P3
major
VERIFIED DUPLICATE of bug 76728
18 years ago
17 years ago

People

(Reporter: Ben Ruppel, Assigned: Blake Ross)

Tracking

Trunk
mozilla0.9.2
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.9) Gecko/20010223
BuildID:    2001022311

Dragging website shortcuts from windows to a mozilla window no longer opens the
site.  Instead, sometimes there is a blank page with info such as: [DEFAULT]
BASEURL=http://XXXX.com/guides/3906/walkthrough.html
[InternetShortcut]
URL=http://XXXX.com/guides/3906/walkthrough.html
Modified=C035D6767DA0C0011F

and most times it gives the download dialog asking how to handle the file (Open
with or save to disk).


Reproducible: Always
Steps to Reproduce:
1.Find shortcut to a web site
2.Drag it to a mozilla browser window
3.Gaze in horror as the web site fails to open

Actual Results:  Text info of url is dieplayed or download dialog pops up asking
how to handle file

Expected Results:  Web site should open

Comment 1

18 years ago
updating component.  probably a duplicate.
Assignee: asa → blakeross
Component: Browser-General → XP Apps: Drag and Drop
QA Contact: doronr → tpreston

Comment 2

18 years ago
Ben, could you please re-try this with a latest build? That would be greatly
appreciated, thank you!
(Reporter)

Comment 3

18 years ago
Hi, I still get the error.  Can anyone reproduce it?  Is it just me?  I went for
two weeks with half of web site graphics not showing up on mozilla, thinking it
was a bug, when erasing my prefs file fixed it.  This problem remains (for me)
in teh 2001031204 build.

Comment 4

18 years ago
Confirming, I see this on 2001-03-10-08, Windows 2000.

Steps I did to reproduce:
1. Right click on desktop, go to New, then select Shortcut.
2. In the "Type the location of the item:" box, enter
'http://www.mozillazine.org'. Click Next.
3. In the "Type a name for this shortcut" box, enter 'Mozillazine'. Click Finish.
4. Open a new Mozilla window, minimize until you see the desktop. Drag the icon
to the Mozilla window in the taskbar, Mozilla opens. Drop it into the page. The
page looks like this:

[InternetShortcut]
URL=http://www.mozillazine.org/
Modified=708C406045ABC0014D

with a URL (on my machine) of
"file:///C:/Documents%20and%20Settings/Administrator/Desktop/Mozillazine.url".

Expected results are, obviously, redirecting to Mozillazine.org. Not sure if
it's a dupe, but it is reproducible on Windows 2000.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Severity: normal → major
Target Milestone: --- → mozilla1.0

Updated

18 years ago
Keywords: mozilla1.0
Target Milestone: mozilla1.0 → ---

Comment 5

18 years ago
I also see this problem on 0.8.1-trunk, build 2001-03-21, on NT4.SP6a.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.2
*** Bug 76878 has been marked as a duplicate of this bug. ***
this can probably be fixed with the patch in 76728
fixed as a part of 76728

*** This bug has been marked as a duplicate of 76728 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.