Interpreter producing incorrect value of 1/-0 in 47.16

VERIFIED FIXED in Q2 12 - Cyril

Status

P2
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: brbaker, Assigned: lhansen)

Tracking

unspecified
Q2 12 - Cyril
x86
Mac OS X
Bug Flags:
in-testsuite +
flashplayer-qrb +
flashplayer-bug -
flashplayer-triage +

Details

(Reporter)

Description

7 years ago
Code:
var z = 0;
print(1/-z);

Expected output:
-Infinity

You will get the expected output if compile WITHOUT -abcfuture (46.16) and run in jit or interp mode. However if you compile with -abcfuture (47.16) then you will get the correct value with jit but will get positive Infinity with the interpreter.

Testmedia:
ecma3/TypeConversion/e9_3_1_3_rt.as
Flags: in-testsuite+
Flags: flashplayer-triage+
Flags: flashplayer-qrb+
Flags: flashplayer-bug-
(Assignee)

Updated

7 years ago
Priority: -- → P2
Target Milestone: --- → Q2 12 - Cyril
(Assignee)

Comment 1

7 years ago
Also true for eval (which creates 47.16 content always on tr-float), so not an ASC problem.
Assignee: nobody → lhansen
(Assignee)

Comment 2

7 years ago
The problem is negate:

-0 => 0
(Assignee)

Comment 3

7 years ago
op_negate neglects to check for zeroIntAtom.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED

Comment 4

7 years ago
changeset: 6967:a3c96881e1fb
user:      Brent Baker <brbaker@adobe.com>
summary:   Bug 703035 - Interpreter producing incorrect value of 1/-0 in 47.16, mark expected failure

http://hg.mozilla.org/tamarin-redux/rev/a3c96881e1fb

Comment 5

7 years ago
changeset: 6985:04fdfa8cdce5
user:      Lars T Hansen <lhansen@adobe.com>
summary:   Fix 703035 - Interpreter producing incorrect value of 1/-0 in 47.16

http://hg.mozilla.org/tamarin-redux/rev/04fdfa8cdce5
You need to log in before you can comment on or make changes to this bug.