Closed Bug 703069 Opened 8 years ago Closed 8 years ago

android.content.pm.PackageManager$NameNotFoundException: Application package plugins not found

Categories

(Firefox for Android :: General, defect, P4, critical)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox13 --- verified

People

(Reporter: mevans, Assigned: snorp)

References

Details

(Keywords: crash, flashplayer, Whiteboard: [native-crash])

Attachments

(2 files)

Attached file logcat file
will attach logcat file (crashed 3 times)
load "com.adobe.flashplayer.FlashPaintSurface" from "plugins" for "/system/lib/plugins/com.adobe.flashplayer/libflashplayer.so"
I/GeckoAppShell( 5783): package not found
I/GeckoAppShell( 5783): android.content.pm.PackageManager$NameNotFoundException: Application package plugins not found
I/GeckoAppShell( 5783): 	at android.app.ContextImpl.createPackageContext(ContextImpl.java:1608)
I/GeckoAppShell( 5783): 	at android.content.ContextWrapper.createPackageContext(ContextWrapper.java:460)
I/GeckoAppShell( 5783): 	at org.mozilla.gecko.GeckoAppShell.loadPluginClass(GeckoAppShell.java:1278)
I/GeckoAppShell( 5783): 	at org.mozilla.gecko.GeckoAppShell.executeNextRunnable(Native Method)
I/GeckoAppShell( 5783): 	at org.mozilla.gecko.GeckoAppShell$GeckoRunnableCallback.run(GeckoAppShell.java:1397)
I/GeckoAppShell( 5783): 	at android.os.Handler.handleCallback(Handler.java:587)
I/GeckoAppShell( 5783): 	at android.os.Handler.dispatchMessage(Handler.java:92)
I/GeckoAppShell( 5783): 	at android.os.Looper.loop(Looper.java:130)
I/GeckoAppShell( 5783): 	at org.mozilla.gecko.GeckoApp$22.run(GeckoApp.java:1113)
I/GeckoAppShell( 5783): 	at android.os.Handler.handleCallback(Handler.java:587)
I/GeckoAppShell( 5783): 	at android.os.Handler.dispatchMessage(Handler.java:92)
I/GeckoAppShell( 5783): 	at android.os.Looper.loop(Looper.java:130)
I/GeckoAppShell( 5783): 	at android.app.ActivityThread.main(ActivityThread.java:3691)
I/GeckoAppShell( 5783): 	at java.lang.reflect.Method.invokeNative(Native Method)
I/GeckoAppShell( 5783): 	at java.lang.reflect.Method.invoke(Method.java:507)
I/GeckoAppShell( 5783): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:907)
I/GeckoAppShell( 5783): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:665)
I/GeckoAppShell( 5783): 	at dalvik.system.NativeStart.main(Native Method)
E/GeckoAppShell( 5783): couldn't find class
D/GeckoAppJava( 5783): IME: run()
D/GeckoAppJava( 5783): IME: v=org.mozilla.gecko.gfx.LayerView@406615f0
D/Zygote  ( 2577): Process 5783 exited cleanly (1)

Matt, which Flash player version do you have installed on your phone? (i.e, Settings -> Applications -> Manage Applications -> Adobe Flash Player (XX.X) -> version
Severity: normal → critical
Keywords: crash, flashplayer
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Summary: nightly build from today 11-16-11 crashes on startup → android.content.pm.PackageManager$NameNotFoundException: Application package plugins not found
Whiteboard: [native-crash]
Blocks: 703167
No longer blocks: 703167
Depends on: 703167
snorp, i know there isn't enough info, but make the stack can help.  any idea why Matt is seeing this?
Assignee: nobody → snorp
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Priority: -- → P4
Resolution: INCOMPLETE → ---
smells like a dup
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703167
I think I see the problem. The package name is derived from the lib path. On my phone (with flash installed from Market) the path is: /data/data/com.adobe.flashplayer/lib/libflashplayer.so

Above we're getting a path in /system, so we just need to be more robust there.
703167 is a bug to add more logging around the problem, not to fix the actual problem. Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #575220 - Flags: review?(blassey.bugs) → review?(doug.turner)
Attachment #575220 - Flags: review?(doug.turner) → review?(blassey.bugs)
Comment on attachment 575220 [details] [diff] [review]
Do a better job of guessing plugin package name

Review of attachment 575220 [details] [diff] [review]:
-----------------------------------------------------------------

talked about this on skype, james will implement comparing data dirs as a first pass
Attachment #575220 - Flags: review?(blassey.bugs) → review-
Comment on attachment 575220 [details] [diff] [review]
Do a better job of guessing plugin package name

after some discussion on irc, we should land this as is and follow up with some logic to test the data dir
Attachment #575220 - Flags: review- → review+
I should have added that this is a startup crash. I am dead-in-the-water for testing native fennec on my device.
https://hg.mozilla.org/projects/birch/rev/00a547135657
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
This crash doesn't occur anymore on the latest Nightly build.

Verified fixed on:

Firefox 13.0a1 (2012-02-17)
20120217031227
http://hg.mozilla.org/mozilla-central/rev/2271cb92cc05

--
Device: Motorola Droid PRO
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.