Incorrect ORGANIZER in icalendar-format invitations

RESOLVED DUPLICATE of bug 459683

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED DUPLICATE of bug 459683
6 years ago
4 years ago

People

(Reporter: urban, Unassigned)

Tracking

Lightning 1.0

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I created a calendar event and sent an invitation to someone (myself under another mail address)


Actual results:

The invitation contains the line:
ORGANIZER;RSVP=TRUE;CN=Mr Organizer;PARTSTAT=ACCEPTED;ROLE=CHAIR:mailto:Mr. Organizer@xxx.yyy.org


Expected results:

According to RFC 5545, the ORGANIZER property should not contain PARTSTAT, RSVP, nor ROLE parameters:


   Property Name:  ORGANIZER

   Purpose:  This property defines the organizer for a calendar
      component.

   Value Type:  CAL-ADDRESS

   Property Parameters:  IANA, non-standard, language, common name,
      directory entry reference, and sent-by property parameters can be
      specified on this property.
Component: General → E-mail based Scheduling (iTIP/iMIP)
QA Contact: general → email-scheduling

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 459683
You need to log in before you can comment on or make changes to this bug.