Make /etc/init.d/vmware-tools chkconfig compliant and re-enable puppet checking

RESOLVED WONTFIX

Status

Infrastructure & Operations
Virtualization
RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: lerxst, Assigned: lerxst)

Tracking

Details

(Assignee)

Description

6 years ago
After one of the phx1 ESX hosts got updated, new vmware tools were installed on all the VMs running on it, and the new version of vmware-tools installs a /etc/init.d/vmware-tools script that isn't compatible with chkconfig (missing the chkconfig stanza at the top). This causes numerous problems, one of which being that the puppet check for vmware-tools running failed.

So, fix the script (maybe install a newer version of vmware-tools that doesn't have the bug?) and re-enable puppet checking.

Example host that has the problem is elasticsearch-dev3.webapp.phx1.mozilla.com
(Assignee)

Comment 1

6 years ago
Turns out this isn't really a problem, it's just that VMware Tools now use UpStart if the host OS supports it, and RHEL 6 does.

http://upstart.ubuntu.com/

I personally detest the entire UpStart idea & implementation, however...

tl;dr:

old: /etc/init.d/vmware-tools {start|stop|status|restart}
new: /etc/vmware-tools/services.sh {start|stop|status|restart}
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: Server Operations → Server Operations: Virtualization
QA Contact: cshields → dparsons
Resolution: --- → WONTFIX
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.