Socorro - replace VARCHAR with TEXT in reports table

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: lars, Assigned: selenamarie)

Tracking

Trunk
Future
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

7 years ago
the reports table uses varchar(n) for many fields.  Most would benefit from having these switched to text without length limits.  That way we can stop truncating signatures. Some fields may even benefit by becoming CITEXT, like the comments field.

This will have ramifications on the processor, and anything that uses signatures.
Component: Socorro → General
Product: Webtools → Socorro

Updated

7 years ago
Target Milestone: 2.5 → 2.5.1

Updated

7 years ago
Target Milestone: 2.5.1 → 2.5.2

Updated

7 years ago
Assignee: nobody → josh
Need to test impact of this.  It may need to wait for our eventual upgrade to PostgreSQL 9.1 or 9.2.

Updated

7 years ago
Whiteboard: [qa+]
Under PostgreSQL 9.0, this will require a full table rewrite, or system table hacking.  

As such, recommend that it be put off until we upgrade to version 9.1 or 9.2.
Target Milestone: 2.5.2 → 4.0
Target Milestone: 4.0 → 6

Updated

6 years ago
Target Milestone: 6 → 7
Not upgraded to 9.1 or 9.2 yet.  Bumping this forwards a lot.
Target Milestone: 7 → 10

Updated

6 years ago
Target Milestone: 10 → Future
Depends on: 757274
Assignee: josh → sdeckelmann
Duplicate of this bug: 794542
(Reporter)

Comment 5

3 years ago
very old and outdate - refile if it is still needed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.