Firefox may show blank for video and requires extra refresh with clearing cache

UNCONFIRMED
Unassigned

Status

()

Core
General
P2
normal
UNCONFIRMED
6 years ago
6 years ago

People

(Reporter: Luda, Unassigned)

Tracking

8 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.120 Safari/535.2

Steps to reproduce:

1. Copy a few video files (ex: mp4, mpg, avi) under any web server on Mac/Apache or Windows (IIS).  Change file permissions if needed to view and play these files in hyperlink.
2. Create a simple HTML file (Ex: "myvideo.html") with hyperlink to these videos and save it under the same Web server.
3. Open Firefox Window/Tab. Navigate to this HTML page.
4. Click on the link to each video. 
5. Repeat step 4 by clicking on the same link again. 
6. Enter <Cmd><R><Shift> to flush browser cache before step 5 and repeat step 5.



Actual results:

1. Video may not display without clearing browser cache and shows blank.
2. It always display after clearing cache (step 6) 




Expected results:

Video displays every time when a user clicks on link. (It works fine in Safari 5.x).
(Reporter)

Comment 1

6 years ago
Does not repro on MacOS 10.6_x86 32 bit.  Firefox 8 has all required plug-ins up-to-date.
   DivX Web Player 2.1.2.265 ;   
   Flip4Mac Windows Media Plugin 2.4.0.11
   QuickTime Plug-in 7.6.6
   Shockwave Flush 11.102.55
Priority: -- → P2
Hardware: x86 → x86_64
You need to log in before you can comment on or make changes to this bug.