superscript does subscript

VERIFIED WORKSFORME

Status

()

Core
Layout
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: Klaus Malorny, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I nearly don't dare to submit the bug as I cannot imagine that noone else made
this observation:

If I tag some text with either the <sup> tag or with the corresponding style
"vertical-align: super", the browser shifts the text _down_ instead up. 

I'll attach a sample file & a screenshot.

Build: 2001022311 (but also many builds before), WinNT4
(Reporter)

Comment 1

18 years ago
Created attachment 26265 [details]
sample file
(Reporter)

Comment 2

18 years ago
Created attachment 26266 [details]
screenshot (PNG)

Comment 3

18 years ago
I can't reproduce this.  In today's debug build on Mac, the sample file 
attachment does appropriate superscripting and subscripting.
(Reporter)

Comment 4

18 years ago
I just realized that I used a Type1 font via Adobe Type Manager Deluxe 4.0. I 
switched to "Verdana" and the problem disappeared. So the problem is eventually 
in the Windows specific part.

Comment 5

18 years ago
Marking worksforme based on the reporter's last comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Marking verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
Sorry, but closing without *real* testing the bug disappoints me a bit :-( .
Nevertheless, I reviewed the GFX code. As it does not seem to contain ATM
specific code in it (at least for the super/subscript values), I assume that the
problem is deeper in the OS or ATM itself.

Well, of course, one could modify /gfx/src/windows/nsFontMetricsWin.cpp lines
2826, 2827 to take the absolute value of the OUTLINETEXTMETRICS fields.
You need to log in before you can comment on or make changes to this bug.