tb2-darwin10-slave69 ran out of disk space

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: standard8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
During the xpcshell-tests on mac, we create a 4GB file as part of a test to check mailboxes work correctly.

I've seen it a couple of times now where the test fails due to out of disk space:

TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | [Exception... "Component returned failure code: 0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE) [nsIOutputStream.close]" nsresult: "0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE)" location: "JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/mailnews/imap/test/unit/test_largeOfflineStore.js :: run_test :: line 100" data: no]
TEST-UNEXPECTED-FAIL | /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/mailnews/local/test/unit/test_over4GBMailboxes.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | [Exception... "Component returned failure code: 0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE) [nsIOutputStream.close]" nsresult: "0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE)" location: "JS frame :: /builds/slave/comm-central-macosx64-opt-unittest-xpcshell/build/xpcshell/tests/mailnews/local/test/unit/test_over4GBMailboxes.js :: run_test :: line 101" data: no]
Currently looks okay:

tb2-darwin10-slave69:slave cltbld$ df -h
Filesystem      Size   Used  Avail Capacity  Mounted on
/dev/disk0s2    74Gi   53Gi   21Gi    72%    /

Might we need to bump up our free space numbers on OS X ?
(Reporter)

Comment 2

7 years ago
What's the current setting for free space for a build?
Possible duplicate of bug 717182?
(Reporter)

Comment 4

7 years ago
(In reply to John Hopkins (:jhopkins) from comment #3)
> Possible duplicate of bug 717182?

I doubt it, but I haven't seen this in a while so I'm going to mark as WFM for now.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.