<xul:window style="overflow:auto;"> doesn't display

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Axel Hecht, Assigned: Eric Vaughan)

Tracking

Trunk
Future
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
If I add a
<?xml-stylesheet href="chrome://communicator/skin/" type="text/css"?>
and a style="overflow:auto;", my window doesn't display anything.
Seems like a regression, didn't happen a few days back (layout split?).

I see the content of my page, and when it tries to apply the style, my content
disappears. I get following assertion:

###!!! ASSERTION: Error scroll port has too many children: 'count <= 1', file
/tmp/mozilla/view/src/nsScrollPortView.cpp, line 415
###!!! Break: at file /tmp/mozilla/view/src/nsScrollPortView.cpp, line 415

Axel
(Reporter)

Comment 1

18 years ago
Created attachment 26268 [details]
file with both stylesheet and overflow
(Reporter)

Updated

18 years ago
Summary: <xul:window style="overflow:auto;"> doesn't display → <xul:window style="overflow:auto;"> doesn't display
(Reporter)

Comment 2

18 years ago
Here is a stack trace when the assertion hits, perhaps that helps:

###!!! ASSERTION: Error scroll port has too many children: 'count <= 1', file
/tmp/mozilla/view/src/nsScrollPortView.cpp, line 415
###!!! Break: at file /tmp/mozilla/view/src/nsScrollPortView.cpp, line 415
0 /tmp/build/dist/bin/libxpcom.so:nsTraceRefcnt::WalkTheStack(FILE *)+0xbc
1 /tmp/build/dist/bin/libxpcom.so:nsDebug::Break(char const *, int)+0x1d0
2 /tmp/build/dist/bin/libxpcom.so:nsDebug::Assertion(char const *, char const *,
char const *, int)+0xec
3
/tmp/build/dist/bin/components/libgkview.so:nsScrollPortView::SetScrolledView(nsIView
*)+0x88
4
/tmp/build/dist/bin/components/libgklayout.so:nsHTMLContainerFrame::CreateViewForFrame(nsIPresContext
*, nsIFrame *, nsIStyleContext *, nsIFrame *, int)+0x8a0
5
/tmp/build/dist/bin/components/libgklayout.so:nsScrollBoxFrame::SetUpScrolledFrame(nsIPresContext
*)+0x140
6
/tmp/build/dist/bin/components/libgklayout.so:nsScrollBoxFrame::InsertFrames(nsIPresContext
*, nsIPresShell &, nsIAtom *, nsIFrame *, nsIFrame *)+0x100
7
/tmp/build/dist/bin/components/libgklayout.so:FrameManager::InsertFrames(nsIPresContext
*, nsIPresShell &, nsIFrame *, nsIAtom *, nsIFrame *, nsIFrame *)+0x250
8
/tmp/build/dist/bin/components/libgklayout.so:nsCSSFrameConstructor::ReconstructDocElementHierarchy(nsIPresContext
*)+0x614
9
/tmp/build/dist/bin/components/libgkcontent.so:StyleSetImpl::ReconstructDocElementHierarchy(nsIPresContext
*)+0x34
10
/tmp/build/dist/bin/components/libgklayout.so:PresShell::ReconstructFrames(void)+0x64
11
/tmp/build/dist/bin/components/libgklayout.so:PresShell::StyleSheetAdded(nsIDocument
*, nsIStyleSheet *)+0x14
12
/tmp/build/dist/bin/components/libgkcontent.so:nsXULDocument::InsertStyleSheetAt(nsIStyleSheet
*, int, int)+0x300
13
/tmp/build/dist/bin/components/libgkcontent.so:CSSLoaderImpl::InsertSheetInDoc(nsICSSStyleSheet
*, int, nsIContent *, int, nsICSSLoaderObserver *)+0x40c
14
/tmp/build/dist/bin/components/libgkcontent.so:CSSLoaderImpl::SheetComplete(nsICSSStyleSheet
*, SheetLoadData *)+0x42c
15 /tmp/build/dist/bin/components/libgkcontent.so:CSSLoaderImpl::Cleanup(URLKey
&, SheetLoadData *)+0xe4
16
/tmp/build/dist/bin/components/libgkcontent.so:CSSLoaderImpl::SheetComplete(nsICSSStyleSheet
*, SheetLoadData *)+0x5c8
17
/tmp/build/dist/bin/components/libgkcontent.so:CSSLoaderImpl::ParseSheet(nsIUnicharInputStream
*, SheetLoadData *, int &, nsICSSStyleSheet *&)+0x20c
18
/tmp/build/dist/bin/components/libgkcontent.so:CSSLoaderImpl::DidLoadStyle(nsIStreamLoader
*, nsString *, SheetLoadData *, unsigned int)+0x128
19
/tmp/build/dist/bin/components/libgkcontent.so:SheetLoadData::OnStreamComplete(nsIStreamLoader
*, nsISupports *, unsigned int, unsigned int, char const *)+0x410
20
/tmp/build/dist/bin/components/libnecko.so:nsStreamLoader::OnStopRequest(nsIRequest
*, nsISupports *, unsigned int, unsigned short const *)+0xb0
21
/tmp/build/dist/bin/components/libnecko.so:nsJARChannel::OnStopRequest(nsIRequest
*, nsISupports *, unsigned int, unsigned short const *)+0x184
22
/tmp/build/dist/bin/components/libnecko.so:nsOnStopRequestEvent::HandleEvent(void)+0x1ac
23
/tmp/build/dist/bin/components/libnecko.so:nsStreamObserverEvent::HandlePLEvent(PLEvent
*)+0x9c
24 /tmp/build/dist/bin/libxpcom.so:PL_HandleEvent+0x84

Comment 3

17 years ago
not a table specific bug, reassigning to core owner.
Assignee: karnaze → attinasi
Reassigning to Eric.
Assignee: attinasi → evaughan
Target Milestone: --- → Future
Attachment #26268 - Attachment mime type: text/xul → application/vnd.mozilla.xul+xml

Comment 5

17 years ago
The testcase appears to render now. Axel, can you confirm whether this is still
a problem?
(Reporter)

Comment 6

17 years ago
I can't reproduce this bug anymore either.
Even if I change the testcase to what is XUL these days.

Axel
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.