Crash opening startup windows

VERIFIED DUPLICATE of bug 40641

Status

SeaMonkey
UI Design
--
critical
VERIFIED DUPLICATE of bug 40641
18 years ago
14 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Paul Chen)

Tracking

({crash})

Trunk
x86
Windows 95
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I had Browser and Mail set to open by default in preferences.
Having just upgraded to build 2001022605 Mozilla now crashes in JS3250.DLL
However if I start mozilla -browser -mail then this works OK.

MOZILLA caused an invalid page fault in
module JS3250.DLL at 0157:60b12a56.
Registers:
EAX=0000001f CS=0157 EIP=60b12a56 EFLGS=00010246
EBX=00000000 SS=015f ESP=0068f2bc EBP=0068f2d0
ECX=0068f30c DS=015f ESI=01157e70 FS=4e87
EDX=0d9ad5e0 ES=015f EDI=01136be0 GS=0000
Bytes at CS:EIP:
8b 48 04 81 f9 c0 44 b5 60 74 0e 85 c9 74 21 8b 
Stack dump:
600a1091 01157e70 0d9ad5e0 01136be0 01156060 0068f314 600a2350 01136be0
01157e70 0d9ad5e0 0068f30c 80000000 01156060 00000000 60bbd0c0 60bb6000 

JS3250! 60b12a56()
CAPS! 600a2350()
JSDOM! 60b64267()
JSDOM! 60b65df4()
GKCONTENT! 60271400()
GKCONTENT! 60271d7a()
JSDOM! 60b61899()
GKCONTENT! 601c497f()
DOCSHELL! 6011364b()
DOCSHELL! 601136e8()
DOCSHELL! 60111949()
DOCSHELL! 60111c48()
URILDR! 6098146b()
URILDR! 60987af2()
URILDR! 60987a13()
NECKO! 606bdbce()
NECKO! 606d8a14()
NECKO! 606a64cf()
(Reporter)

Comment 1

18 years ago
Today it's the other way around... mozilla -browser -mail crashes...
Summary: Crash opening default startup windows → Crash opening startup windows
i cannot get this to crash using 2001.02.28.11 bits [opt comm] on winnt. neil,
is this still a problem for you using today's bits?

side note: speaking of having mail and browser set, there's also bug 64025 --but
not sure if you're experiencing that, since it's dealing with the tooltip
pref...
Severity: minor → critical
Keywords: crash
(Reporter)

Comment 3

18 years ago
I don't know why, but one particular menulist was giving me grief.
Today that menulist is working, and so is the startup...
If I don't have any problems next Monday I'll mark this invalid.
(Reporter)

Comment 4

18 years ago
I think it's something to do with the 3rd party theme I was using :-(

If I reset the theme (e.g. to Classic) it all works OK.

So this is actually a dup of 40641.

*** This bug has been marked as a duplicate of 40641 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
bug 40641 (Need recovery mechanism for install of evil/broken skins) itself has
been suggested as  a dupe for bug 47277 (M16,M17 missing css components (ie gif
file) stops window displaying)
however veryfying this as a dupe of 40641 and will mark that accordingly..
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.