Charset Menu: Arabic, Hebrew menu items should move to "Middle Eastern" section

VERIFIED FIXED in mozilla0.9.1

Status

()

VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: nhottanscp, Assigned: mkaply)

Tracking

({intl})

Trunk
mozilla0.9.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
In the trunk build, there are new menu items for Arabic and Hebrew.
They should move under "Middle Eastern" section.
(Reporter)

Comment 1

18 years ago
Created attachment 26299 [details]
A screen shot of the current charset menu, Arabic and Hebrew items are not propery located.

Comment 2

18 years ago
Over to bidi team...
Assignee: nhotta → mkaply
(Reporter)

Updated

18 years ago
Summary: Charset Menu: Arabic, Hebrew menu items should move "Middle Eastern" section → Charset Menu: Arabic, Hebrew menu items should move to "Middle Eastern" section

Comment 3

18 years ago
adding keyword intl.
Keywords: intl

Comment 4

18 years ago
Created attachment 26670 [details] [diff] [review]
patch to fix this issue.

Comment 5

18 years ago
r=timeless
(Assignee)

Comment 6

18 years ago
*** Bug 75477 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
Hi Mike, please take a look at bug 74741, submitted by Maha (IBM Egypt):

  http://bugzilla.mozilla.org/show_bug.cgi?id=74741

Comment 8

18 years ago
Mike - Please accept this one as nsbeta1 and assigned a milestone of M0.9.1
Keywords: nsbeta1

Updated

18 years ago
QA Contact: andreasb → ylong
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 9

18 years ago
Created attachment 32158 [details] [diff] [review]
Don't include hidden menuitems
(Assignee)

Updated

18 years ago
Depends on: 74741
(Assignee)

Comment 11

18 years ago
erik, can i get an sr on this one?
(Assignee)

Comment 13

18 years ago
Fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 14

18 years ago
I still see Arabid and Hebrew charset menu items have not been moved to "Middle
Eastern" section on 05-01 trunk build?

Comment 15

18 years ago
I'm re-open this bug at this point.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 16

18 years ago
Are you refering to the x-mac-charsets?

This is a completely different issue.

These charsets are missing names, and there are more than just arabic and 
hebrew ones.

I chose not to move them to the menu so people wouldn't forget they need to be 
fixed

Comment 17

18 years ago
If this is a different issue, let's close this and open a new bug.

Comment 18

18 years ago
Trunk build 2001050104 on US Win95
I see the problem in today's build (yesterday's build crashed on launch).

Under Middle Eastern, I only see Visual Hebrew.

Under More, I see the {Arabic,Hebrew} for {IBM, ISO, Windows}.

We probably should file a bug about the Mac ones as well.

Comment 19

18 years ago
I checked navigator.properties in my just installed chrome\en-US.jar.
And the change is not there:
   intl.charsetmenu.browser.more5=iso-8859-8

Maybe this is a build issue because I see the change in
  
http://lxr.mozilla.org/seamonkey/source/xpfe/browser/resources/locale/en-US/navi
gator.properties
(Assignee)

Comment 20

18 years ago
I built clean and they are in my Middle Eastern menus.

Maybe there is a dependency issue with navigator.properties?
(Reporter)

Comment 21

18 years ago
There is a commercial version of navigator.js, let me apply the patch and check in.

Comment 22

18 years ago
Ugh!  Keeping this info in 2 places is just asking for trouble.
Can this info be moved to a single place in the mozilla tree.
(Reporter)

Comment 23

18 years ago
I agree, filed as bug 78552.
(Reporter)

Comment 24

18 years ago
checked in the commercial change
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
Verified on 05-11 trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.