Last Comment Bug 703456 - Kill REPORT_BUILD; kill it dead
: Kill REPORT_BUILD; kill it dead
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla11
Assigned To: Nicholas Nethercote [:njn]
:
Mentors:
Depends on: 705332
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-17 17:17 PST by Nicholas Nethercote [:njn]
Modified: 2011-11-30 21:46 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
diff (15.08 KB, patch)
2011-11-17 18:05 PST, Nicholas Nethercote [:njn]
ted: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2011-11-17 17:17:17 PST
Builds are too verbose.  I build with "make -s --no-print-directory" and yet the name of every file that is compiled still gets printed like this:

 [...]
 jsarray.cpp
 jsatom.cpp
 jsbool.cpp
 jscntxt.cpp
 jsclone.cpp
 jscompartment.cpp
 [...]

This is due to REPORT_BUILD, the commit log for which was this:

  3.181 <jim_nance@yahoo.com> 2000-02-24 19:55
  Adding commands to print out the file getting built. This increases the usefulness of make -s

That's right, it took non-trivial effort to produce that spew.  I guess ol' Jim Nance wanted something between "silence" and "great big compiler invocations".  Sorry, Jim;  silence is golden.

Patch coming in a bit.  If this breaks something about the build I'm gonna cry.
Comment 1 Nicholas Nethercote [:njn] 2011-11-17 18:05:38 PST
Created attachment 575354 [details] [diff] [review]
diff

This patch reduces the number of lines of output during a clobber debug build on my Linux64 box from 12687 to 7114.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-11-21 05:12:06 PST
Comment on attachment 575354 [details] [diff] [review]
diff

Review of attachment 575354 [details] [diff] [review]:
-----------------------------------------------------------------

Fine with me, I never use "make -s", and if you are using it it seems like you'd want less output.
Comment 3 Nicholas Nethercote [:njn] 2011-11-21 18:50:45 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/9838cc0b62ee
Comment 4 Ed Morley [:emorley] 2011-11-22 09:08:49 PST
https://hg.mozilla.org/mozilla-central/rev/9838cc0b62ee
Comment 5 Brian Hackett (:bhackett) 2011-11-26 14:30:16 PST
Is there a way to get the names of compiled files without all the trash output that 'make' otherwise generates?  I really like(d) the output from make -s, since I could tell at a glance where in the build process a given directory was.  I often have several builds going on at once, or a build and something else, and this clean output makes triage easier and more efficient than if there is no output at all.
Comment 6 Gregory Szorc [:gps] 2011-11-26 14:35:57 PST
If we were using PyMake as the official build tool, we could hook into its API and build rich reporting not otherwise possible with GNU make. I have some work around this in bug 683438. It just needs to be hooked up to the build system.
Comment 7 Bobby Holley (:bholley) (busy with Stylo) 2011-11-30 17:35:45 PST
I agree with bhackett, and am bummed about this. The spew wasn't overwhelming (the way normal spew is), and without it there's no way to tell how far along a build is. It's also nice to know what had to be rebuilt when changing headers and IDL and the like.

Ted, how would you feel about putting this back in and making the 'echo' configurable?
Comment 8 Jeff Walden [:Waldo] (remove +bmo to email) 2011-11-30 21:46:47 PST
(In reply to Bobby Holley (:bholley) from comment #7)
See bug 705332 in this bug's dependencies.

Note You need to log in before you can comment on or make changes to this bug.