Closed Bug 703556 Opened 10 years ago Closed 10 years ago

Move account settings into preferences

Categories

(Thunderbird :: Preferences, defect, P4)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 286664

People

(Reporter: for.bugzilla, Unassigned)

Details

When users configure their program, they always look in the preference panel (and surely on mac, as this is the only place all the prefs can be changed)
So it is not more than logically the account settings for Thunderbird are also integrated in the preferences panel, instead of being a separate item.

This bug has not a high priority, but would reduce complexity and overall consistency.
Is your suggestion to just add a button "Account Settings" to the Options dialog, similar to the way how it currently allows opening the Add-ons Manager for the General tab there? That indeed would be straightforward to implement.

However, if you want to move the enter Account Manager into that dialog, this would be a major overhaul of the entire implementation (and the Options dialog is substantially smaller than the Account Settings window, thus you cannot easily squeeze it into the Options window as an overlay or something similar).
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 286664
The suggestion was to move the account settings into the pref panel, not only a button to it, however that would also be better.

Sorry for the dupe.
You need to log in before you can comment on or make changes to this bug.