Last Comment Bug 703575 - nsIJSInspector throws NS_ERROR_XPC_BAD_IID errors in debugger unit tests
: nsIJSInspector throws NS_ERROR_XPC_BAD_IID errors in debugger unit tests
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on:
Blocks: 697762
  Show dependency treegraph
 
Reported: 2011-11-18 06:29 PST by Panos Astithas [:past]
Modified: 2011-11-18 10:45 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (1.02 KB, patch)
2011-11-18 07:52 PST, Panos Astithas [:past]
dcamp: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2011-11-18 06:29:49 PST
Though they work fine for me locally, the debugger xpcshell tests fail in the try run at:

https://tbpl.mozilla.org/?tree=Try&rev=425c360240ca

The error is:

TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | [Exception... "Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]"  nsresult: "0x80570018 (NS_ERROR_XPC_BAD_IID)"  location: "JS frame :: /home/cltbld/talos-slave/test/build/xpcshell/tests/toolkit/devtools/debugger/tests/unit/test_getyoungestframe.js :: run_test :: line 4"  data: no]

The browser tests fail as well, due to the same cause.
Comment 1 Panos Astithas [:past] 2011-11-18 07:52:58 PST
Created attachment 575458 [details] [diff] [review]
Fix

As explained to me by bsmedberg, this went undetected because we always ran the binary from obj-ff-dbg/dist/ightly.app, not from the result of 'make package'.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=202c0d9b0cdb

Note You need to log in before you can comment on or make changes to this bug.