Last Comment Bug 70363 - Inconsistent Build ID on nightly build!
: Inconsistent Build ID on nightly build!
Status: VERIFIED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: P2 normal (vote)
: mozilla0.9.1
Assigned To: cls
: Jon Granrose
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 13:37 PST by Deven Corzine
Modified: 2005-11-22 15:05 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Deven Corzine 2001-02-27 13:37:27 PST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17 i686)
BuildID:    2001022705/2001022711

I downloaded the most recently nightly build, and found that the build ID
reported is inconsistent.  This makes it difficult to file consistent bug
reports.

Reproducible: Always
Steps to Reproduce:
1. Run "./mozilla --version" and note Build ID number in output.
2. Run "./mozilla" and note Build ID number in browser title bar.
3. Compare build ID numbers.

Actual Results:  The build ID numbers are different.

Expected Results:  The build ID numbers should be identical.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2001-02-27 14:27:22 PST
I'm seeing this sort of thing too.
Comment 2 Jon Granrose 2001-02-27 15:00:09 PST
ooh, this is a beaut.

I tried today's mozilla 2001-02-27-13 linux trunk build.

  --version reports 2001-02-27-05
  titlebar reports 2001-02-27-14
  dated directory reports 2001-02-27-13

This is bad.  We really really should have one buildid for all three.

This may be a duplicate of an existing bug, but the --version behavior is new to
me.  cc'ing leaf.  I'm going to set m0.9 just because this has been biting us
for so long it would be good to be finally done with it.
Comment 3 Daniel (Leaf) Nunes 2001-02-27 17:04:16 PST
i didn't even know we *had* a --version option! my bugs are all for windows 
inconsistencies... so this is probably not a dupe.
Comment 4 cls 2001-03-09 00:34:28 PST
Yay...more fallout from bug 26798.  The funny thing is that we do have a single
variable that we use to set the date (with the exception of layout's gbdate.pl).
  --version uses NS_BUILD_ID which is set in config/nsBuildID.h . Whenever we
build in config/ with BUILD_OFFICIAL set, the build_number will *always* be
updated (if it will be different) causing nsBuildID.h to always be updated. 
What it looks like is that nsBuildID.h is being regenerated after
xpfe/bootstrap/nsAppRunner.cpp is built.  And I bet this is caused by the PSM
builds.  The psm build traverses config/ but not xpfe/.
Comment 5 Jon Granrose 2001-04-16 17:43:49 PDT
are we any closer to a fix for this?
Comment 6 cls 2001-04-16 18:00:14 PDT
Well, part of this problem will resolve itself when we switch to building psm2
as part of the build (still working on the win32 nss autoconf issues).  Then the
titlebar & datedir will be sync'd.  I'll have to dig a bit to figure out the
--version problem.
Comment 7 cls 2001-04-17 20:50:24 PDT
Jon, I'm not sure why your test showed --version being so far off but I
downloaded today's gcc295 nightly and --version, the window title and the
directory all matched up.  Since we're still doing the separate pass for
building psm2, I think there's still a chance it may be off in the future.  It
may depend upon the build machine. (gcc295 was done by myotonic).

Comment 8 Jon Granrose 2001-04-18 09:56:47 PDT
I'd be more interested in seeing what's happening with the 8am builds since I
suspect part of the problem is due to depend builds and since the 4/5am and 8pm
builds are full clobbers I wouldn't expect to see the problem there.
Comment 9 cls 2001-04-20 13:05:38 PDT
With the 2001-04-19-08 mozilla-i686 nightly, I'm seeing all of the version
numbers being synced up as well.  So we can either mark this fixed or slide it
down to 0.9.1. We are still waiting for psm/nss to be intergrated into the
normal build (post 0.9) which would avoid the second build pass.   Right now,
the datestamp offset appears to be contigent upon how long the 8am depend build
takes and whether the subsequent psm depend build is also done in the 8 o'clock
hour.
Comment 10 Jon Granrose 2001-05-08 15:46:59 PDT
I concur and don't see this problem with the most recent 2001-05-08-14 linux
builds either.  user agent buildid, titlebar buildid, --version, and date dir
all show the same date/time.

resolving.
Comment 11 Jon Granrose 2001-05-08 15:47:43 PDT
verifying.

Note You need to log in before you can comment on or make changes to this bug.