Last Comment Bug 703663 - Intermittent test failures in browser_dbg_script-switching.js
: Intermittent test failures in browser_dbg_script-switching.js
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
: James Long (:jlongster)
Mentors:
Depends on:
Blocks: 697762
  Show dependency treegraph
 
Reported: 2011-11-18 11:08 PST by Panos Astithas [:past]
Modified: 2011-11-21 11:26 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Working patch (1.15 KB, patch)
2011-11-21 07:24 PST, Panos Astithas [:past]
dcamp: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2011-11-18 11:08:00 PST
From the try run at: https://tbpl.mozilla.org/?tree=Try&rev=202c0d9b0cdb

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_script-switching.js | The first script is displayed again.
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_script-switching.js :: testSwitchRunning :: line 75
    JS frame :: chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_script-switching.js :: <TOP_LEVEL> :: line 67
    JS frame :: chrome://mochikit/content/browser-test.js :: <TOP_LEVEL> :: line 418
Comment 1 Panos Astithas [:past] 2011-11-21 07:24:13 PST
Created attachment 575858 [details] [diff] [review]
Working patch

The bug is that the test is triggered on the wrong event. scriptsadded is the proper event to start the test on, because when it fires it changes the list box items unbeknownst to the test code.

Note You need to log in before you can comment on or make changes to this bug.