Last Comment Bug 703670 - Intermittent test failures in browser_dbg_propertyview-08.js
: Intermittent test failures in browser_dbg_propertyview-08.js
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
:
Mentors:
Depends on:
Blocks: 697762
  Show dependency treegraph
 
Reported: 2011-11-18 11:21 PST by Panos Astithas [:past]
Modified: 2011-11-21 11:27 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Working patch (1.97 KB, patch)
2011-11-21 07:00 PST, Panos Astithas [:past]
dcamp: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2011-11-18 11:21:26 PST
From the try run at: https://tbpl.mozilla.org/?tree=Try&rev=202c0d9b0cdb

DBG-CLIENT: Error handling response: TypeError: this._view is null - ()@resource:///modules/source-editor-orion.jsm:434
SE_getCharCount()@resource:///modules/source-editor-orion.jsm:619
SS_addScript([object Proxy])@chrome://browser/content/debugger.js:388
SS_onScripts("scriptsadded")@chrome://browser/content/debugger.js:360
EV_notify("scriptsadded")@resource:///modules/dbg-client.jsm:160
([object Proxy])@resource:///modules/dbg-client.jsm:543
DC_onPacket([object Proxy])@resource:///modules/dbg-client.jsm:370

TEST-INFO | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-08.js | Console message: [JavaScript Error: "this._view is null" {file: "resource:///modules/source-editor-orion.jsm" line: 434}]
DBG-SERVER: Got: {
  "to": "conn15.obj10",
  "type": "prototypeAndProperties"
}
DBG-SERVER: Got: {
  "from": "conn15.obj10",
[..]
}
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_propertyview-08.js | application timed out after 330 seconds with no output
args: ['arch', '-arch', 'i386', '/usr/sbin/screencapture', '-C', '-x', '-t', 'png', '/var/folders/Xr/Xr--yJnSEY0U11ET5NZuMU+++TM/-Tmp-/mozilla-test-fail_wghPmT']
SCREENSHOT: data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAABkAAAASwCAIAAAAsYxHAAAABAWlDQ1BJQ0M[...]
Cj0IYsSJPbcRe8U7H7f8By5X7+Ez2AigAAAAASUVORK5CYII=
Can't trigger Breakpad, just killing process
INFO | automation.py | Application ran for: 0:12:24.503823
INFO | automation.py | Reading PID log: /var/folders/Xr/Xr--yJnSEY0U11ET5NZuMU+++TM/-Tmp-/tmpaoeKCrpidlog
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!
Comment 1 Panos Astithas [:past] 2011-11-21 07:00:50 PST
Created attachment 575849 [details] [diff] [review]
Working patch

The cause was a recent change in the Orion initialization, which made it asynchronous. I also fixed a small bug in the stylesheet, introduced in bug 700695.

Note You need to log in before you can comment on or make changes to this bug.