Last Comment Bug 703687 - Revise help links to external resources
: Revise help links to external resources
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Help Documentation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey2.11
Assigned To: Jens Hatlak (:InvisibleSmiley)
:
:
Mentors:
: 732139 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 11:54 PST by neil@parkwaycc.co.uk
Modified: 2012-04-15 13:57 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
patch (1.26 KB, patch)
2012-03-18 08:38 PDT, Jens Hatlak (:InvisibleSmiley)
neil: review+
Details | Diff | Splinter Review
patch v1a [Checkin: Comments 7 and 11] (1.30 KB, patch)
2012-03-19 12:33 PDT, Jens Hatlak (:InvisibleSmiley)
jh: review+
iann_bugzilla: approval‑comm‑aurora+
iann_bugzilla: approval‑comm‑beta+
Details | Diff | Splinter Review

Description neil@parkwaycc.co.uk 2011-11-18 11:54:28 PST
Some of the external links in Help pages point to outdated or missing pages.
Comment 1 Jens Hatlak (:InvisibleSmiley) 2012-02-27 14:44:35 PST
I wonder whether we should hijack this bug for fixing the links on the initial Help page (since the bug is otherwise a bit unspecific):

chrome://communicator/locale/help/welcome_help.xhtml

1. Troubleshooting
Is now a 404. Existing alternatives:
* https://wiki.mozilla.org/SeaMonkey/FAQ
  (+) specific to SM
  (+) under our control and easy to update
  (-) is a FAQ, not really troubleshooting info
* http://support.mozilla.org/kb/Basic%20Troubleshooting
  (+) contains rather generic troubleshooting info
  (-) advertises FF
  (-) is subject to change / not under our control
* http://www.seamonkey-project.org/releases/seamonkey2.1/#troubleshooting
  (+) specific to SM
  (+) under our control
  (-) version-specific
* http://seamonkey.ilias.ca/troubleshooting/
  (+) specific to SM
  (-) not under our control
  (-) not updated anymore, probably outdated

2. PluginDoc
Outdated, should be http://www.mozilla.org/plugincheck/ instead (even if it advertises FF; also linked from the AOM).
Comment 2 Chris Ilias [:cilias] 2012-03-02 13:46:07 PST
*** Bug 732139 has been marked as a duplicate of this bug. ***
Comment 3 Jens Hatlak (:InvisibleSmiley) 2012-03-18 08:38:50 PDT
Created attachment 606975 [details] [diff] [review]
patch
Comment 4 neil@parkwaycc.co.uk 2012-03-18 15:25:54 PDT
Comment on attachment 606975 [details] [diff] [review]
patch

>+      <p><strong><a href="http://www.seamonkey-project.org/releases/seamonkey2.1/#troubleshooting">Troubleshooting</a></strong></p>
As you're the website owner I assume you chose this version for a reason ;-)

>+      <p><strong><a href="http://www.mozilla.org/plugincheck//">Plugin Check</a></strong></p>
Nit: doubled trailing slash. r=me with that fixed.
Comment 5 Jens Hatlak (:InvisibleSmiley) 2012-03-19 12:30:29 PDT
(In reply to neil@parkwaycc.co.uk from comment #4)
> >+      <p><strong><a href="http://www.seamonkey-project.org/releases/seamonkey2.1/#troubleshooting">Troubleshooting</a></strong></p>
> As you're the website owner I assume you chose this version for a reason ;-)

Yeah, it was among those with the most pros, and then I decided to favor what is actually about troubleshooting, as the link label suggests.

Meanwhile I've slightly changed my mind again: We can do better. Instead of hard-coding a (section of a) page from an old release, we can hard-code a more generic page and let our website redirect to the page I suggested until we change our mind and create the page for real or move it elsewhere. :-)


added redirect for troubleshooting link from SeaMonkey Help

Checking in src/.htaccess;
/www/seamonkeyproject-org/src/.htaccess,v  <--  .htaccess
new revision: 1.28; previous revision: 1.27
done

# flexible solution for hard-coded link in SeaMonkey Help
Redirect temp /doc/troubleshooting http://www.seamonkey-project.org/releases/seamonkey2.1/#troubleshooting
Comment 6 Jens Hatlak (:InvisibleSmiley) 2012-03-19 12:33:17 PDT
Created attachment 607261 [details] [diff] [review]
patch v1a [Checkin: Comments 7 and 11]

[Approval Request Comment]
Regression caused by (bug #): mozilla.org website changes
User impact if declined: 404/broken/bad links
Testing completed (on m-c, etc.): n/a
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: yes, but existing Help page only
Comment 7 Jens Hatlak (:InvisibleSmiley) 2012-03-19 12:38:19 PDT
Comment on attachment 607261 [details] [diff] [review]
patch v1a [Checkin: Comments 7 and 11]

http://hg.mozilla.org/comm-central/rev/198828399b50
Comment 8 Jens Hatlak (:InvisibleSmiley) 2012-03-19 12:39:50 PDT
(In reply to neil@parkwaycc.co.uk from comment #0)
> Some of the external links in Help pages point to outdated or missing pages.

If there's more, let's do that in new bugs, with explicit references to what's obsolete or missing. :-)
Comment 9 Jens Hatlak (:InvisibleSmiley) 2012-04-02 08:57:24 PDT
Ian: Ping for branch approvals.
Comment 10 Ian Neal 2012-04-02 14:34:38 PDT
Comment on attachment 607261 [details] [diff] [review]
patch v1a [Checkin: Comments 7 and 11]

a=me with relevant posting to L10n groups if required
Comment 11 Jens Hatlak (:InvisibleSmiley) 2012-04-15 13:56:37 PDT
Comment on attachment 607261 [details] [diff] [review]
patch v1a [Checkin: Comments 7 and 11]

http://hg.mozilla.org/releases/comm-aurora/rev/4b081e67789b
http://hg.mozilla.org/releases/comm-beta/rev/e3db2ddc1840

Note You need to log in before you can comment on or make changes to this bug.