[GTK Themes] The URL field gets garbled sometimes

VERIFIED FIXED in M15

Status

()

Core
XUL
P4
minor
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: Daniel Roberts, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
This might be related to the bug 7036 that I just filed...  I don't know.
Anyway, it seems that with certain GTK themes, most notably BeOS (found on
gtk.themes.org), the URL field gets garbled when I try to select it or otherwise
type anything over it, since the original text never gets repainted until I
force the area to get re-painted by an expose event (i.e., switching virtual
desktops back and forth, or minimizing/restoring the window).  I am attaching a
screenshot of the problem.  Also, it seems to affect more than just the URL
field, though I cannot readily say offhand just how many things seem to be
affected.
(Reporter)

Comment 1

19 years ago
It can be difficult to reproduce sometimes--it seems to happen intermittently.
I will post a screenshot when next I see the problem.

Updated

19 years ago
Assignee: trudelle → pavlov
Priority: P3 → P4
Target Milestone: M12

Comment 2

19 years ago
URL field is not an XPToolkit widget.  What else is affected?  Reassigning to
pavlov@pavlov.net as p4 for m12.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
as per the other bug, what version of gtk are you using?
(Reporter)

Comment 4

19 years ago
As per 7036, GTK 1.2.1.
(Reporter)

Comment 5

19 years ago
Created attachment 299 [details]
Here is the promised screenshot.  Sorry I had to reduce it to a very low-quality JPEG to make it small enough (<64k) to attach.  But I think it should still get the point across.
(Assignee)

Updated

19 years ago
Summary: The URL field gets garbled sometimes → [GTK Themes] The URL field gets garbled sometimes
Target Milestone: M12 → M15
(Assignee)

Comment 6

19 years ago
moving gtk theme related bugs to M15
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

19 years ago
I am not sure what was causing the original problem, but in any case, this bug
is no longer an issue, since Mozilla switched to GFX widgets. :-)  So I say we
might as well mark this bug fixed and get it off the radar altogether, so we can
concentrate on more important things.  Everyone agree?

Updated

18 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.