Not setting background in CSS

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: sanderson, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The background of the referenced URL should be white. 

Reproducible: Always
Steps to Reproduce:
Visit the URL.
Um... looking at the code, the page sets a background-image and no
background-color...  Is that correct?

The page shows up identically in Mozilla and NS 4.x; I don't have IE to test it
with.

Scott, since you seem to be working on the site, could you let us know where in
the code you are setting the background color (the image is set in bgLoad.js)?

Thanks,
Boris
(Reporter)

Comment 2

18 years ago
Well, I just updated to build 2001022608, and the background is still grey.
Additionally, I notice that the upper top of the tree+road image does not appear
in Mozilla.

In Netscape 4.75 the background is white, and the entirety of the image is
visible.

I'm under Gnome with X 4.0.2 if that makes a difference to your testing.  I can
also provide screenshots and/or preference settings if that helps.
I am seeing a gray background with Netscape 4.73, Mozilla 2001-02-25-21, Mozilla
2001-02-26-08, and Netscape 4.76 on two different systems.

Do your Netscape preferences perhaps set a white backround color for pages as
the default?  

As for the image, I see the problem you are describing.  I will try to figure
out what's causing that.  But that should be a separate bug.
(Reporter)

Comment 4

18 years ago
I asked the web page developer to comment on the problem.

Apparently it isn't so much the background color, as the image itself. My
mistake. He should be posting a clarification soon, though. (*poke* Steve)

Comment 5

18 years ago
It's not that it isn't setting the backbround-color... 

Here's the problem, after the page loads the background-image property of a 
specific object is given a value, it fails to display background-image.

I have build-ID:2001020704 and it works with this build... Mr. Anderson is using 
a later build and this is how it came to my attention.
I just went back to the page to test this and figure out the problem, and it's
been changed so that it now shows up identically in Mozilla and Netscape 4.7

Is this bug still an issue?  If so, could you possibly provide the old version
of the page as a testcase?  (I'm using the 2001-03-02 build)
Steve?  Scott?  Is this bug still present in recent builds?  is it still an issue?

Comment 8

18 years ago
Page looks fine in the April 3rd build. Marking verified works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.