Crash occurs when switching orientation in full screen video mode

RESOLVED WORKSFORME

Status

()

P2
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: nhirata, Assigned: cpeterson)

Tracking

({crash, reproducible})

unspecified
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(fennec11+)

Details

(Whiteboard: [native-crash:P1], URL)

Attachments

(1 attachment)

1. go to http://people.mozilla.com/~nhirata/html_tp/elephants-dream.webm
2. long tap to get the full screen
3. go to full screen mode
4. switch orientations (from landscape to portrait or vice versa)

Expecte: no crash
Actual: crash
Created attachment 575571 [details]
logcat

Mozilla/5.0 (Android; Linux armv7I; rv: 11.0a1) Gecko/20111118 Firefox/11.0a1 Fennec/11.0a1

Looks like a layers issue?

11-18 14:39:01.236: D/GeckoInputConnection(2482): IME: run()
11-18 14:39:01.236: D/GeckoInputConnection(2482): IME: v=org.mozilla.gecko.gfx.LayerView@45a38d00
11-18 14:39:01.510: W/dalvikvm(2482): threadid=7: thread exiting with uncaught exception (group=0x400208b0)
11-18 14:39:01.533: E/AndroidRuntime(2482): FATAL EXCEPTION: GLThread 8
11-18 14:39:01.533: E/AndroidRuntime(2482): java.lang.IllegalArgumentException
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at java.nio.Buffer.position(Buffer.java:271)
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at org.mozilla.gecko.gfx.TileLayer.uploadTexture(TileLayer.java:164)
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at org.mozilla.gecko.gfx.TileLayer.onDraw(TileLayer.java:98)
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at org.mozilla.gecko.gfx.Layer.draw(Layer.java:54)
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at org.mozilla.gecko.gfx.LayerRenderer.onDrawFrame(LayerRenderer.java:131)
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at android.opengl.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1332)
11-18 14:39:01.533: E/AndroidRuntime(2482): 	at android.opengl.GLSurfaceView$GLThread.run(GLSurfaceView.java:1116)
11-18 14:39:01.596: W/ActivityManager(1237):   Force finishing activity org.mozilla.fennec/.App
Severity: normal → critical
Keywords: reproducible
Whiteboard: [native-crash] → [native-crash:P1]

Updated

7 years ago
Priority: -- → P3

Updated

7 years ago
Priority: P3 → P2

Updated

7 years ago
Assignee: nobody → cpeterson
(Assignee)

Comment 2

7 years ago
WORKSFORME. I can reproduce the exception in build 20111118, but the exception "went away" the next day in build 20111119.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 3

7 years ago
Note that the exception "went away" but this video test does not play correctly in fullscreen because of a different bug.
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.