SVG gradients do not render from another SVG

RESOLVED DUPLICATE of bug 353575

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 353575
6 years ago
6 years ago

People

(Reporter: Strager Neds, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_7) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2

Steps to reproduce:

Reference symbol A of SVG A in a separate SVG B.


Actual results:

Gradients of symbol A do not render properly in SVG B.

If you copy the gradient elements of SVG A into SVG B, it displays properly (i.e. bug is not present).  Suitable workaround if it wasn't for the memory hit


Expected results:

Symbol A should render identically in both SVG A and SVG B.
(Reporter)

Comment 1

6 years ago
Created attachment 575563 [details]
Test case HTML
(Reporter)

Comment 2

6 years ago
Created attachment 575564 [details]
Test case SVG (dynamically loaded by firefox-bug.html)
(Reporter)

Comment 3

6 years ago
Works fine in:

Chrome 13
Opera 11.52
Safari 5.0.5
Safari iOS 4, 5
Android Browser 3.2.1
Blackberry PlayBook (Webkit)

Does NOT work in:

Firefox 8.0 (OS X 10.6)
Firefox Nightly (OS X 10.6)
Android Firefox
Firefox 8.0 (Ubuntu x86_64)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353575
You need to log in before you can comment on or make changes to this bug.