mirrored textures with webgl

RESOLVED DUPLICATE of bug 702058

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 702058
7 years ago
6 years ago

People

(Reporter: gal, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
If you go to 

http://andreasgal.github.com/gaia/

using a Nightly all textures are mirrored horizontally.

With Firefox 8.0 everything is fine.

I use Mac OS X (10.7).
I can't reproduce this problem on Linux.

By horizontally do you mean that left and right are interchanged? Can you attach a screenshot?
Any gfx folks have a 10.7 machine on which they can try this out?  This sounds like a disturbing regression, if it's real.
Benoit has one in the Toronto office that's available for us to use. (He's on vacation this week, though.)
I have a 10.7 machine, and will test this shortly.
moz-central build doesn't exhibit and mirroring for me. Page is identical for Release and moz-central builds.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111121 Firefox/11.0a1
ATI Technologies Inc. -- AMD Radeon HD 6630M OpenGL Engine -- 2.1 ATI-7.12.9
I have a MacPro desktop with 10.5, 10.6, 10.7 that you can use, you'll just need someone in Toronto to boot it. Let me know if you need the login details and I'll email them.
Andreas, can you paste the "Graphics" info from about:support here?
Is this fixed by using the pref "cgl.prefer-fbo=true"?

Comment 9

7 years ago
dupe of bug 702058 ?
Marking as duplicate of 'upside-down contexts' bug. Please reopen if this bug is different and still present.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702058
You need to log in before you can comment on or make changes to this bug.