performance timing tests involving document.open fail

RESOLVED FIXED in mozilla17

Status

()

Core
Document Navigation
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

Trunk
mozilla17
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

See W3C test in url field.

Igor, Olli, can one of you please look into this?

Comment 1

6 years ago
I looked into this problem a bit, it's not easy to tell events caused by document.open and subsequent calls from the normal load. To fix the issue we might let to register each event in the NavigationTiming only once, so that load process caused by document.open does not affect collected data.
Duplicate of this bug: 712561

Updated

6 years ago
OS: Mac OS X → All
Hardware: x86 → All
Version: 9 Branch → Trunk
Duplicate of this bug: 754310

Comment 4

5 years ago
Can we get an owner here? Is Igor planning to fix this?

Comment 5

5 years ago
Sorry, I don't have capacity right now
I just read through the navigation timing processing model pretty carefully, and I think this test is wrong.  Or the spec is wrong.  One or the other.  Posted http://lists.w3.org/Archives/Public/public-web-perf/2012May/0122.html
The spec has been clarified to match the test.
Created attachment 647685 [details] [diff] [review]
Don't update performance timing or navigation timing state during document.open.
Attachment #647685 - Flags: review?(jst)
Assignee: nobody → bzbarsky
Whiteboard: [need review]
Oh, sicking and smaug, if you think you're a better reviewer for this, please feel free to steal!
Comment on attachment 647685 [details] [diff] [review]
Don't update performance timing or navigation timing state during document.open.

Sorry for the delay, looks all good! r=jst
Attachment #647685 - Flags: review?(jst) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3e9040a6eb9
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla17
Sorry, backed out in

https://hg.mozilla.org/integration/mozilla-inbound/rev/e3e9040a6eb9

for two consecutive new Linux64 Opt M2 failures

352 ERROR TEST-UNEXPECTED-FAIL | /tests/docshell/test/test_bug570341.html | Expected domContentLoadedEventStart to happen before domContentLoadedEventEnd, got domContentLoadedEventStart = 1344485549757, domContentLoadedEventEnd = 0
Er, yes.  That's because the constructor wasn't setting the booleans for those two.  Damn castability of boolean to int...

Relanded with that fixed as https://hg.mozilla.org/integration/mozilla-inbound/rev/cc595773e189
If it makes you feel any better, I spent about an hour today chasing down a bug that ended up being passing (bool, int) when I meant (int, bool), with no warning :/.
https://hg.mozilla.org/mozilla-central/rev/cc595773e189
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.