Last Comment Bug 703874 - Remove redundant |ifneq (mobile,$(MOZ_BUILD_APP))| from makefiles in browser/*
: Remove redundant |ifneq (mobile,$(MOZ_BUILD_APP))| from makefiles in browser/*
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: All All
: -- trivial (vote)
: Firefox 11
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-19 06:19 PST by Ed Morley [:emorley]
Modified: 2011-12-01 04:41 PST (History)
3 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.72 KB, patch)
2011-11-19 06:23 PST, Ed Morley [:emorley]
khuey: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-11-19 06:19:19 PST
There are a few instances of |ifneq (mobile,$(MOZ_BUILD_APP))| in makefiles in browser/* which are obviously redundant. 

Two of the three instances are recent, and have been most likely copied from the third (browser/devtools/webconsole/Makefile.in), which original existed in toolkit (http://hg.mozilla.org/mozilla-central/rev/2cf6a6d0f962), where the check was obviously necessary.

http://mxr.mozilla.org/mozilla-central/search?string=mobile&find=%2Fbrowser%2F.*\.in
Comment 1 Ed Morley [:emorley] 2011-11-19 06:23:01 PST
Created attachment 575660 [details] [diff] [review]
Patch v1
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-22 02:48:44 PST
Thanks for telling us about this, and fixing it. I'm removing bug 582596 and bug 583041 from the blocks lists because they're closed.
Comment 4 Marco Bonardo [::mak] 2011-12-01 04:41:18 PST
https://hg.mozilla.org/mozilla-central/rev/e837d33a508b

Note You need to log in before you can comment on or make changes to this bug.