Closed Bug 703922 Opened 10 years ago Closed 10 years ago

about:config: modifying boolean prefs needs 4 taps

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: steffen.wilberg, Assigned: Margaret)

References

Details

Attachments

(1 file)

With the new about:config, you need 4 taps (clicks) to toggle a boolean pref:
1. Tap Modify
2. Tap on the menulist
3. Tap false or true
4. Tap OK

With the XUL version, you only needed 2 taps:
1. Tap the pref once to activate it
2. Tap it again to toggle the boolean value (don't need to tap the checkbox, you can tap the pref label as well)

On desktop Firefox, you just double-click a boolean pref to toggle it.
No longer blocks: 699418
Depends on: 699418
Even better: Toggle a boolean pref back and forth:
1. Tap "Modify" on e.g. accessibility.browsewithcaret (default false)
1a. Don't notice that False is selected, and press OK.
1b. Notice that you didn't toggle the pref, and tap Modify again.
2. Tap on the menulist.
3. Tap "true".
4. Tap OK.
5. To toggle it back, tap Modify again (ignoring the Reset button)

Result: a textbox filled with "true" and the cursor blinking at the start of it. Looks like it expects me to tap the textbox, delete "true" and type in "false" letter by letter...
Comment 0 (In reply to Steffen Wilberg from comment #0)
> With the new about:config, you need 4 taps (clicks) to toggle a boolean pref:
> 1. Tap Modify
> 2. Tap on the menulist
> 3. Tap false or true
> 4. Tap OK
> 
> With the XUL version, you only needed 2 taps:
> 1. Tap the pref once to activate it
> 2. Tap it again to toggle the boolean value (don't need to tap the checkbox,
> you can tap the pref label as well)
> 
> On desktop Firefox, you just double-click a boolean pref to toggle it.

Yes, this is definitely something we can improve. We just tried to do the simplest thing possible in bug 699418. Something like a "Toggle" button for booleans would probably be relatively simple to make.

(In reply to Steffen Wilberg from comment #1)
> Even better: Toggle a boolean pref back and forth:
> 1. Tap "Modify" on e.g. accessibility.browsewithcaret (default false)
> 1a. Don't notice that False is selected, and press OK.
> 1b. Notice that you didn't toggle the pref, and tap Modify again.
> 2. Tap on the menulist.
> 3. Tap "true".
> 4. Tap OK.
> 5. To toggle it back, tap Modify again (ignoring the Reset button)
> 
> Result: a textbox filled with "true" and the cursor blinking at the start of
> it. Looks like it expects me to tap the textbox, delete "true" and type in
> "false" letter by letter...

This isn't expected behavior and it's definitely pretty weird. We may even want to file a separate bug about this, since it's something we can likely fix without making inline prefs.
Attached patch patchSplinter Review
This patch changes the "Modify" button for boolean prefs to a "Toggle" button, which just toggles the existing value.

I also found a typo where I had written a "=" instead of a "==", which was what caused the weird pref type change. Also, this code now actually does the right thing when a pref has been removed!
Assignee: nobody → margaret.leibovic
Status: NEW → ASSIGNED
Attachment #576243 - Flags: review?(mark.finkle)
Attachment #576243 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/projects/birch/rev/6cdbeceb2846
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Samsung Nexus S (Android 2.3.6)
20111123040207
http://hg.mozilla.org/projects/birch/rev/cd5725c23a13
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.