Last Comment Bug 70394 - need to check in nsIBidi.h and implementation
: need to check in nsIBidi.h and implementation
Status: RESOLVED FIXED
: intl
Product: Core
Classification: Components
Component: Internationalization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla0.8.1
Assigned To: Erik van der Poel
: mimi fruchter
: Makoto Kato [:m_kato]
Mentors:
: 68718 (view as bug list)
Depends on: 1031395
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 16:33 PST by Erik van der Poel
Modified: 2014-06-27 11:11 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
nsIBidi.h (24.88 KB, text/plain)
2001-03-01 17:16 PST, Erik van der Poel
no flags Details
nsBidiImp.h (17.12 KB, text/plain)
2001-03-01 17:17 PST, Erik van der Poel
no flags Details
nsBidiImp.cpp (72.88 KB, text/plain)
2001-03-01 17:17 PST, Erik van der Poel
no flags Details

Description Erik van der Poel 2001-02-27 16:33:08 PST
The Unicode bidi algorithm is implemented in IBM's nsBidiImp.{cpp,h}, and the
interface is in nsIBidi.h.

Frank, as module owner for mozilla/intl, please review.
Comment 1 Frank Tang 2001-03-01 17:11:49 PST
please add the file to attachment
Comment 2 Erik van der Poel 2001-03-01 17:16:08 PST
Created attachment 26581 [details]
nsIBidi.h
Comment 3 Erik van der Poel 2001-03-01 17:17:02 PST
Created attachment 26582 [details]
nsBidiImp.h
Comment 4 Erik van der Poel 2001-03-01 17:17:55 PST
Created attachment 26583 [details]
nsBidiImp.cpp
Comment 5 Gervase Markham [:gerv] 2001-03-02 12:24:36 PST
*** Bug 68718 has been marked as a duplicate of this bug. ***
Comment 6 Andreas Becker 2001-03-02 15:58:10 PST
adding keyword intl.
Comment 7 Erik van der Poel 2001-03-06 17:46:24 PST
r=ftang
sr=erik

This code is mostly copied from IBM's ICU implementation of the Unicode Bidi
Algorithm, and has been ported to Mozilla's XPCOM/NS/PR conventions.
Comment 8 Erik van der Poel 2001-03-06 17:52:49 PST
Files checked in.
Comment 9 Andreas Becker 2001-03-13 19:40:09 PST
Erik, can you provide IQA with steps how to verify this bug or with a test case?
Setting QA Contact to erik@netscape.com for now.
Comment 10 Andreas Becker 2001-03-19 14:03:39 PST
Changing QA Contact to mimi_fruchter@hotmail.com.  Mimi, are these information
sufficient for you to verify this Bug?

Note You need to log in before you can comment on or make changes to this bug.