Closed Bug 704019 Opened 13 years ago Closed 13 years ago

automatic mailto: link clicking crashes computer

Categories

(Core :: DOM: Navigation, defect, P1)

x86_64
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 566893

People

(Reporter: tekwiz, Unassigned)

Details

(Whiteboard: [sg:dos])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111116091359

Steps to reproduce:

I came across webpage that uses javascript or some other scripting language  to periodically click or activate a mailto link in a webpage every millisecond.


Actual results:

When the webpage opened send to Email boxes began to pop up filling my screen with windows. I was unable to close the tab the webpage was loaded on because Firefox hand frozen due to the amount of send to Email it was opening. I tried opening Windows task manager to end the Firefox application but was unable to because the end task dialog box was lost in the mess of send to Email windows. I was finally able to log-out of my account using the Alt-Ctrl-Delete key combination to open the Alt-Ctrl-Delete screen new to windows 7.

To add to the problem I had installed a session manager addon in my Firefox. I was unable to open Firefox without causing another session of Send to windows popping up! I had to run Firefox with addons disabled and clear my previous session before I could Firefox again!



Expected results:

I would suggest that you put a limit on the amount of mailto links 
that can be opened in a certain amount of time!
You could also make a confirmation box like the alert box that would ask the user if they want to open the mailto link.
The confirmation box could also ask what Email client to use.
Severity: normal → critical
Priority: -- → P1
Group: core-security
Status: UNCONFIRMED → NEW
Component: General → Document Navigation
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → docshell
Whiteboard: [sg:dos]
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: