Invalidating Core Animation plugin crashes on Mac OS X 10.5 32 bits

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Emmanuel BUU, Unassigned)

Tracking

({crash})

8 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.41 MB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Created attachment 575781 [details]
Modified sample

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_5_8) AppleWebKit/534.50.2 (KHTML, like Gecko) Version/5.0.6 Safari/533.22.3

Steps to reproduce:

I compiled the NetscapeCoreAnimationMoviePlugin sample from Apple 

http://developer.apple.com/library/safari/#samplecode/NPAPI_Core_Animation_Movie_Plugin/Introduction/Intro.html

after some twicks (added InvalidatingCoreAnimation support and some other stuff to get it compile correctly under 10.5 and I loaded test.html in FF8


Actual results:

The FF8 program crashed but without triggering a report and in the Mac OS console, I noticed the following trace:

21/11/11 00:55:35 firefox[90336] Mozilla has caught an Obj-C exception [CANoTransaction: thread has no current transaction] 


Expected results:

Plugin should have at least loaded.

Updated

3 years ago
Severity: normal → critical
Component: General → Untriaged
Keywords: crash
I didn't managed to reproduce this issue on the latest release(43.0.4) nor the latest Nightly(46.0a1).

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160113030208

Can you please try to reproduce this on the latest release(43.0.4) and latest Nightly(46.0a1) and provide the results?
When doing this, you could create a new clean Firefox profile, or maybe test in safe mode, as some of this issues may be caused by third party installed addons or custom settings
(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thank you,
Vlad
Flags: needinfo?(emmanuel.buu)
Hi,

Considering the fact that the reporter did not provide more informations on my request, I will mark this issue as Resolved - WFM.
If you can still reproduce this, feel free to reopen it and provide the requested information.

Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(emmanuel.buu)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.