Calendar Reminders Lost with Provider for Google Calendar 0.9

RESOLVED WORKSFORME

Status

Calendar
Provider: GData
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Bob Reckhow, Unassigned)

Tracking

Lightning 1.0
x86
Windows Vista

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

My configuration:
     Windows Vista Ultimate, Service Pack 2, all the latest updates applied
     Thunderbird 8.0
     Lightning 1.0
     Provider for Google Calendar 0.9

My Google calendar is created in the free version of Google Apps, and it is sync'ed to my iPhone 3GS {IOS 5.0.1 (9A405)} via Google Apps Sync (Exchange).

Most of my events on my iPhone (and in Google Calendar) are recurring events, but these issues occur with both recurring events and one-time events.

Most of my events (both recurring and one-time, in both iPhone and Google Calendar) have a single Reminder set (called "Alert" on the iPhone). None have more than one Alert/Reminder set (i.e., a few have zero, but most have one reminder)


Actual results:

All of the events from my Google Calendar appear in my calendar in Thunderbird/Lightning/Provider.
BUT...

1. In the Month/Multiweek/Week/Day calendar views, none of these events show the bell icon for a reminder.

2. When I open any event in Thunderbird, the Reminder drop-down shows "No reminder" even if it has a Reminder in Google.

3. When I change the Reminder drop-down in Thunderbird to any other value (e.g., 2 days before) and then hit the "Save and Close" button,
     (a) No bell icon appears beside the event listing in the calendar view, and
     (b) When I reopen the panel for editing the event, the Reminder drop-down has gone back to "No reminder".


Expected results:

1. Reminders from my Google Calendar should be transferred to my Thunderbird/Lightning/Provider calendar, just like all the other event attributes are.

2. The reminder bell icon should be visible in Thunderbird beside the event (for all events that do have a reminder in Google) in all views: Month, Multiweek, Week, Day, and the panel for viewing/editing all event details.

3. After changing the reminder in the event panel in Thunderbird and pressing "Save and Close", the reminder change should persist in both the calendar views and the detailed event view/change panel.
(Reporter)

Updated

7 years ago
OS: All → Windows Vista
Hardware: All → x86
Could you enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor (prefs > advanced > general > config editor) and then try adding a such event again?

I believe we have another bug on this filed, but I could never reproduce it :-(
Component: Alarms → Provider: GData
QA Contact: alarms → gdata-provider
(Reporter)

Comment 2

7 years ago
I enabled verbose calendar logging. Then I tried to add a reminder in Thunderbird Calendar to an event that already had that reminder in the Google Calendar. I actually did that a few times to confirm that the reminder was not there in the Thunderbird calendar.

Then I went to the Google Calendar, and saw that the reminder was missing there, too. So I went to my iPhone and found the reminder missing there, too. The name of the event in this case was "Rod Lunch".

Then, I went to a different (repeating) event (the name is "Mindfulness") and confirmed that the reminder was there in both my iPhone and Google, but not in Thunderbird. I opened the Thunderbird panel for it (all occurrences), and saw that it said "No reminder". I changed that to "2 days before" (same as the reminder that was already there in Google and iPhone) and hit the "Save and Close" button. No bell icon showed up in my monthly calendar view for this event. So I opened the edit all occurrences panel again, and saw "No reminder". This time, instead of "Save and Close", I just closed the window.

Then I looked back at my Google Calendar, refreshed the screen, and saw that the reminder was gone. Then I looked at my iPhone, and the reminder was still there, but it disappeared within a few seconds.

So to me, this seems to confirm that synchronization between Google Calendar and my iPhone is working correctly, and fairly quickly. Synchronization from Thunderbird to Google Calendar also seems to be working as well, since the erroneous deletion of the reminder was propagated promptly on "Save on Close".

What seems not to be working is that synchronization from Google to Thunderbird loses the reminders, and then Thunderbird can't add a reminder back. This "loss" of a reminder is then only propagated back to Google when the event is changed in some way.

I confirmed this last scenario using a different event ("Call Pico Lino for Dec 20 Tue Update"). I confirmed that it had a "2 days before" reminder in both iPhone and Google Calendar, but not in Thunderbird. Then in Thunderbird, I changed only the name of the event (to "Call to Pico Lino...", i.e., inserting the word "to"), but never touching the Reminders drop-down; leaving it as "No reminder". After hitting "Save and Close" on the Thunderbird edit event panel, the name change for the event was propagated to both Google and iPhone within seconds, and in both places, the reminder had been deleted.

Now, how can I get this verbose calendar log to you?

Also, would it be of any value for me to do this again with another event while making before-and-after screen shots of the event details in Google and/or Thunderbird? (I don't know of a way to do the equivalent on my iPhone.)
(Reporter)

Comment 3

7 years ago
Then I tried another experiment. Using the event from my last experiment ("Call [to] Pico Lino for Dec 20 Tue Update"), I tried to see what happens when I edit an event on my iPhone. What I did was two things: (1) I removed the word "to" from the event name, and (2) I set the reminder (called "alert" on iPhone) back to "2 days before". In iPhone, when done finishing an edit of an event, the only two options are "this occurrence only" or "all future occurrences" (i.e., there is no option to change previous occurrences. I was editing the November 29 occurrence, so the ones before that were not changed. This essentially changes one repeating event into two: one before the change and one after.

Sure enough, in Google, the "to" was still there in the event occurrences before Nov 29, and it was removed from all occurrences from Nov 29 onwards. Moreover, the 2-day reminder was added to those latter occurrences.

In my Thunderbird calendar, the "to" was removed from Nov 29 and onwards, but this series did not have reminders.

One more experiment:
This time I created a new event on my iPhone ("Test non-recurring event with 2 day reminder"), which was NOT a recurring event, on Nov 26 at 13:00. It propagated quickly and accurately to Google, and then to Thunderbird, but the reminder was lost. So this "reminder losing" bug does not depend on the event being recurring. I still don't know if it depends on the type of reminder (I have always used "2 days before").

Comment 4

7 years ago
My own tests (Provider 0.9, Lighting 1.0, SeaMonkey 2.5b3 on OS/2; Palm PrePlus) are inconclusive. Sometimes an update from one client does not fully propagate to the other, even though Google takes the update, and an update from Google does not get pushed to either client.

In the absence of empirical data (log file) this *feels* like a Google issue and not related to Provider.

BTW, I can't find my log file, even though I do have verbose logging enabled.
(Reporter)

Comment 5

7 years ago
Another experiment: This one is really weird.

In Thunderbird (TB) Calendar, I added a new (non-repeating) event called "Test from TB with reminder" on Nov 26 at 14:00. My default reminder in TB is "2 days before", so I just left it that way when I created the event. I clicked "Save" on the Event menu, not the "Save and Close" button on the Edit Event panel in TB.

This event now shows up in Google with "2 days before", and on my iPhone with an Alert of "2 days before". It shows up on my TB calendar with no bell icon.

Then I went back to the TB Edit Event panel, which was still open. The reminder showed "2 days before" and the bell, as it had when I first opened that panel to create the event. I clicked on the "Close X" in the upper right corner of the window (Windows Vista), and a panel popped up saying "Event has not been saved. Do you want to save the event?" The panel had 3 buttons: "Save", "Don't Save", and "Cancel". I clicked "Cancel".

Then I clicked "Save" in the Event menu again. Then in the Event menu I clicked "Close", and the same panel popped up. I hit Cancel again. No matter how I tried to separate "Save" from "Close", the panel popped up.

So in desperation, I tried "Don't Save" on the panel. The Edit Event panel closed, and when I reopened it, the reminder for the event had been changed to "No reminder". I closed the panel again (with "Don't Save"), leaving the inconsistency in reminders between TB (without) and the other two platforms (with the reminder).

So TB can propagate a reminder to Google on creation of a new event, but the reminder isn't kept in the TB calendar. Any attempt to reintroduce the reminder into the TB calendar (by using the Edit Event panel) fails, and moreover removes the reminder from Google.
(Reporter)

Comment 6

7 years ago
I have been doing all of these experiments with verbose calendar logging on. Please tell me how to find and submit this log.
Thanks!
You can see the log in the error console. If you want to copy/paste more than one entry, the Console^2 extension might be of help.

Comment 8

7 years ago
Ah, of course (I forgot). Also need to turn on "All" instead of just "Errors" in order to see log entries.

Thanks for the tip about the Console^2 extension, Philipp!

BTW, I have caching turned on at the moment. Bob, have you enabled caching? I'm wondering whether this might have some impact on this behavior.

Comment 9

7 years ago
(In reply to Lewis Rosenthal from comment #8)
> Ah, of course (I forgot). Also need to turn on "All" instead of just
> "Errors" in order to see log entries.
> 
...or just "Messages"...
(Reporter)

Comment 10

7 years ago
Created attachment 576671 [details]
Verbose Calendar Log of the "experiments" I have described
(Reporter)

Comment 11

7 years ago
I don't know anything about caching. I never changed any setting for it, so I assume I must be in whatever the default state is.

I installed the Console^2 extension, opened the Error Console (whose appearance is a little different than before Console^2), clicked "All", Control-A to select all, Control-C to copy, and pasted into a Notepad file, which I saved on my desktop as "TB Log 2011-11-23.txt". I will add it as an attachment.
(Reporter)

Comment 12

7 years ago
Philipp,

Have I given you enough to work on? Please let me know if there is anything else I can do to help.

It is very important for me to have this bug fixed. From my experience with Outlook, I have become very dependent on reminders for organizing my activities every day.

Before I switched to Google Apps (which can sync calendars directly with iPhone) I had an extra step in the chain from iPhone to TB (iPhone -> Outlook [via iTunes] -> Google [via "Google Calendar Sync"] -> TB/Lightning [via Provider]). That complicated process worked, at least some of the time, and I got my desktop reminders from Outlook. The process was not effective or reliable, however, because it relied on syncing my iPhone to Outlook via iTunes, which only happened when I physically connected my iPhone to my computer.

The advantages to the Google Apps solution are that it is all "push" (almost instant) technology, and it allows me to remove my reliance on another Microsoft application (Outlook - I use gContact Sync for contacts - better than Zindus). My goal is to eventually get to an "all open source software" configuration.

Thanks,
Bob
Bob, to be honest there is a lot of information in this bug and its hard for me to find the specific bits that help find the error, so lets try to keep it specific:

* Attach the log messages that happen when adding an event in Lightning.
* Reload remote calendars, extract the log message containing the event you just added

Next you could try synchronizing with the non-apps part of Google Calendar to see if this is Google Apps specific or not.

Then you could try enabling the cache to see if the issue persists there. The caching can be enabled in the properties dialog for the calendar (right click on the calendar in the calendar list).
There has been a major rewrite of the Provider for Google Calendar between version 0.32 and 1.0. A vast number of bugs have been fixed during this rewrite, therefore I am closing lots of old bugs that I think might either be fixed or no longer apply to the latest version.

Please read the updated FAQ [1] for details on known issues. If you can reproduce your issue with the latest version of the Provider for Google Calendar and you can't find an existing bug that handles your case, please reopen this issue.

Thank you for your understanding.

[1] https://wiki.mozilla.org/Calendar:GDATA_Provider
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.