Pausing a Flash Player fullscreen Video and permitting screensaver does not repaint correctly.

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Rob, Unassigned)

Tracking

11 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 575807 [details]
OS's Screen after dropping out of Screensaver with a paused fullscreen Video.

When on YouTube sometimes it is necessary to pause Flash Player Video (that is playing in fullscreen).

After some time (when the Video is paused and the Computer is unused) the screensaver will activate.

Hitting a Key or moving the Mouse will deactivate the screensaver but Firefox does not repaint the Screen correctly.

What you end up with is:

1. Firefox's Chrome (restored to last position and size), 'on top'.
2. The Operating System's Taskbar.
3. The paused Video still in fullscreen ('under the Chrome').

See attachment of the Screenshot.


Note (Dupe Searches (IE: 1+2-3 ~= _this_ Bug)):
1. Closely related (but different issue) Bug 636973 - Menu bar appears in FF fullscreen after exiting flash video fullscreen .
2. Closely related (but they claim YouTube 'works' and does not involve Screensaver)Bug 606913 - Some Flash videos do not repaint after leaving fullscreen .
3. (Not related but to be considered when fixing _this_ Bug) Bug 517870 - Fullscreen video should disable screensaver during playback
(Reporter)

Comment 1

6 years ago
Attempts to reproduce this _today_ have not been successful, but I've had a couple of Updates since filing this Report. If it no longer occurs I will close this on the weekend.
(Reporter)

Comment 2

6 years ago
The only problem remaining is that the OS's Menu Bar lingers for a moment _prior_ to going fullscreen (IE: the opposite conditions of Bug 636973 mentioned in Comment 0).

I'll close this since the problems stated in Comment 0 no longer occur.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

6 years ago
ReOpened.

This problem is back, and pausing is no longer a requirement.

Even if the video has played to the end, if you are in 'Fullscreen Mode' and the Screensaver has activated, when you come out of fullscreen the Desktop does not redraw correctly.

You need to restart the Video, goto fullscreen, and hit [ESC] to leave fullscreen; then the Desktop will be redrawn.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

6 years ago
Attachment #575807 - Attachment description: OS's Screen after dropping out of Screensaver whith a paused fullscreen Video. → OS's Screen after dropping out of Screensaver with a paused fullscreen Video.
(Reporter)

Comment 4

6 years ago
Created attachment 580709 [details]
Desktop after Screensaver has ended when it was started after a completed 'fullscreen Flash Video'.

Here is what this Bug currently looks like when a 'fullscreen Flash Video' is ran to completion, the OS's Screensaver activates, and is ended (without coming out of 'fullscreen' _first_).
(Reporter)

Comment 5

6 years ago
This still occurs with Nightly but now it looks a little different.

I seem to recall that when I first reported this that the screen would be redrawn, when you came out of the Screensaver, in 'a few pieces' (and all the pieces were present) with the non-fullscreen drawn over the fullscreen image (and moving the mouse did not affect the image).

With the _current_ version of Firefox the screen only partially redraws (all the pieces are not present) and mousing over the image will cause more of it to be redrawn (still superimposed over the now unwanted fullscreen image).
(Reporter)

Comment 6

6 years ago
At this moment the operation of Nightly has changed yet again.

Now when the Screensaver is about to activate the Flash Player leaves fullscreen mode and thus avoids the situation where the Screensaver would active while the Browser's Flash Player is in fullscreen.

While not exactly fixed the operation is changed so that the Bug can not trigger.

I'll check on Aurora and close as WFM shortly.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.