Last Comment Bug 704089 - Enable IDN Display for .срб
: Enable IDN Display for .срб
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Gervase Markham [:gerv]
:
Mentors:
: 721720 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 03:04 PST by RNIDS
Modified: 2012-03-29 14:57 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Enable IDN display for.pdf (158.05 KB, application/pdf)
2011-11-21 03:04 PST, RNIDS
no flags Details
Patch v.1 (1.01 KB, patch)
2012-02-27 05:05 PST, Gervase Markham [:gerv]
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description RNIDS 2011-11-21 03:04:02 PST
Created attachment 575829 [details]
Enable IDN display for.pdf

User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)

Steps to reproduce:

Enter IDN domain names .срб ( xn--90a3ac )


Actual results:

Firefox display punicode, only.


Expected results:

Firefox display IDN domain name.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-21 05:16:11 PST
Gerv, do you handle these, or someone else?
Comment 2 Gervase Markham [:gerv] 2011-11-21 05:40:05 PST
bz: jothan is first point of contact these days.

Gerv
Comment 3 Jothan Frakes 2011-11-21 10:19:21 PST
While Mozilla uses the whitelist TLD process for mixed script security on cookies and location bar rendering, the presence of Cyrillic and Latin combined in a mixed script string is problematic.

In reviewing the policy and codepoints, I note that there is not any policy about mixed script registration, and there are present a number of visually identical characters in particular between Cyrillic and Latin (LDH) characters.

Example : 
The example of paypal in mixed script confusable is www.pаypal.срб [www.xn--pypal-4ve.xn--90a3ac] seems possible under currently defined policy at registry.
Comment 4 RNIDS 2011-11-21 12:38:59 PST
Mixed script is not allowed in .срб. Only Serbian Cyrillic characters are alowed. The princip is the same as .рф.
[www.xn--pypal-4ve.xn--90a3ac] is not possible. There is no l in Serbian Cyrillic.
p, a, y are visually identical characters, but different characters with different codes. Same as Russian .рф.
Comment 5 Jothan Frakes 2011-11-21 15:15:48 PST
Thank you for clarifying that there is NO MIXED script registration under .срб. Tomislav.  I apparently misread LDH as being also allowed, I apologize for any grief.

While caxap or other whole-string situations where a string could be composed of characters that could spell something appearing to look like Latin, it is entirely unlikely in the presence of a Cyrillic only policy that these would be mistaken, and “рачра1” would not be so visually similar it would confuse anyone, IMHO.

At this time, I propose it be added, and I will work on the patch file(s) required. 

In following our process, could I please have two votes of approval from within our development community?
Comment 6 Gervase Markham [:gerv] 2011-11-22 01:39:04 PST
If only Serbian Cyrillic is allowed, then that's fine.

Gerv
Comment 7 Gervase Markham [:gerv] 2012-01-27 07:42:58 PST
*** Bug 721720 has been marked as a duplicate of this bug. ***
Comment 8 RNIDS 2012-01-27 07:52:24 PST
Any news about this? When do we can expect the patch?
Comment 9 Slobodan Markovic 2012-01-27 09:57:12 PST
Guys, PLEASE fix this as soon as possible - .срб TLD went public today!! http://www.rnids.rs/en/what-s-new/srb-domain-registration-begins/id/3428

Here's the info requested here http://www.mozilla.org/projects/security/tld-idn-policy-list.html for .срб TLD:

- TLD: .срб (.xn--90a3ac)
- Registry (RNIDS) homepage: http://rnids.rs
- Rulebook on .срб sunrise: http://rnids.rs/data/DOKUMENTI/Rules-commencement-SRB.pdf
- Rulebook on registration of .срб domains: http://rnids.rs/data/DOKUMENTI/RegistrationSRB.pdf (permitted character set defined in Article 2(3), also on IANA site http://www.iana.org/domains/idn-tables/tables/rs_sr-rs_1.0.pdf)

You can contact Mr. Tomislav Ciganovic (tomislav.ciganovic@rnids.rs), CTO of RNIDS, for any further clarification.

Thanks,
Sloba
Comment 10 Gervase Markham [:gerv] 2012-02-21 10:08:04 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/3a3a2fc1c1ac

Gerv
Comment 11 Ed Morley [:emorley] 2012-02-22 10:47:34 PST
https://hg.mozilla.org/mozilla-central/rev/3a3a2fc1c1ac
Comment 12 Gervase Markham [:gerv] 2012-02-27 05:05:48 PST
Created attachment 600872 [details] [diff] [review]
Patch v.1
Comment 13 Gervase Markham [:gerv] 2012-02-27 05:06:07 PST
Comment on attachment 600872 [details] [diff] [review]
Patch v.1

[Approval Request Comment]
User impact if declined: IDNs not working (displaying as gibberish) in relevant domain.
Testing completed (on m-c, etc.): Policy rather than code change; but patch has baked over the weekend.
Risk to taking this patch (and alternatives if risky): Very low.
String changes made by this patch: None.

Gerv
Comment 14 Alex Keybl [:akeybl] 2012-02-27 15:31:34 PST
Comment on attachment 600872 [details] [diff] [review]
Patch v.1

[Triage Comment]
Assuming this has gone through all the proper processes, approving for Aurora 12 and Beta 11. We do not expect to see any regressions caused by this patch which, as Gerv notes, is really just policy change.
Comment 16 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-05 16:36:33 PST
Is there anything QA can do to verify this fix?

Note You need to log in before you can comment on or make changes to this bug.