NullPointerException @ gfx.TileLayer.getTextureID(TileLayer.java:82)

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aaronmt, Assigned: kats)

Tracking

({crash})

unspecified
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox13 verified)

Details

(Whiteboard: [native-crash], strwanted)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
E/AndroidRuntime( 1189): FATAL EXCEPTION: GLThread 9
E/AndroidRuntime( 1189): java.lang.NullPointerException
E/AndroidRuntime( 1189): 	at org.mozilla.gecko.gfx.TileLayer.getTextureID(TileLayer.java:82)
E/AndroidRuntime( 1189): 	at org.mozilla.gecko.gfx.SingleTileLayer.onTileDraw(SingleTileLayer.java:97)
E/AndroidRuntime( 1189): 	at org.mozilla.gecko.gfx.TileLayer.onDraw(TileLayer.java:106)
E/AndroidRuntime( 1189): 	at org.mozilla.gecko.gfx.Layer.draw(Layer.java:74)
E/AndroidRuntime( 1189): 	at org.mozilla.gecko.gfx.LayerRenderer.onDrawFrame(LayerRenderer.java:130)
E/AndroidRuntime( 1189): 	at android.opengl.GLSurfaceView$GLThread.guardedRun(GLSurfaceView.java:1363)
E/AndroidRuntime( 1189): 	at android.opengl.GLSurfaceView$GLThread.run(GLSurfaceView.java:1118)
I/GeckoApp( 1189): Got message: Preferences:Data
--
Samsung Nexus S (Android 2.3.6)
20111121040255
http://hg.mozilla.org/projects/birch/rev/41b63b2b6420
Duplicate of this bug: 703937
Assignee: nobody → kgupta
Created attachment 575883 [details] [diff] [review]
Guard against null texture ids
Attachment #575883 - Flags: review?(pwalton)
Comment on attachment 575883 [details] [diff] [review]
Guard against null texture ids

Review of attachment 575883 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with a comment explaining why the null check is done. Good catch.
Attachment #575883 - Flags: review?(pwalton) → review+
https://hg.mozilla.org/projects/birch/rev/2b458bfe5a17
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified fixed on:

Firefox 13.0a1 (2012-02-17)
20120217031227
http://hg.mozilla.org/mozilla-central/rev/2271cb92cc05

--
Device: Motorola Droid PRO
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
status-firefox13: --- → verified
You need to log in before you can comment on or make changes to this bug.