Can't accept certificate with Javascript disabled

VERIFIED DUPLICATE of bug 65378

Status

--
minor
VERIFIED DUPLICATE of bug 65378
18 years ago
2 years ago

People

(Reporter: aoliva, Assigned: ddrinan0264)

Tracking

1.0 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-0.99.23 i686; en-US; 0.8)
Gecko/20010215
BuildID:    2001021503

If I open the URL above when Javascript is disabled in the browser, the first
window that is opened (in which I'm offered the option to view the certificate)
is not closed when I click on `next'.  Nevertheless, a second window is opened,
but, when I click choose to accept the certificate and click on finish, nothing
happens.  After a number of minutes, the connection times out.  As soon as I
enabled Javascript, everything worked just fine.

Reproducible: Always
Steps to Reproduce:
Disable Javascript.

Open https://savannah.gnu.org/account/login.php

Click on `Next'.

Click on `Finish'.


Actual Results:  Nothing happens for a couple of minutes, then it times out.

Expected Results:  It should have opened the URL in the SSL section.

Note that you don't need a login to be able to reproduce the problem. If you
prefer, https://savannah.gnu.org/account/register.php should also work.  Both
are accessible from http://savannah.gnu.org.
Unfortunately, none of the PSM user interface works correctly when JavaScript is
disabled...

*** This bug has been marked as a duplicate of 65378 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
Mass changing Security:Crypto to PSM
Component: Security: Crypto → Client Library
Product: Browser → PSM
Version: other → 2.1

Comment 4

18 years ago
Mass changing Security:Crypto to PSM

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.