Last Comment Bug 704184 - Find a better way to scroll web console output
: Find a better way to scroll web console output
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
:
Mentors:
Depends on:
Blocks: 678152 GCLI-SHIP
  Show dependency treegraph
 
Reported: 2011-11-21 09:30 PST by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-01-10 14:49 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
upload 1 (7.18 KB, patch)
2011-12-12 05:06 PST, Joe Walker [:jwalker] (needinfo me or ping on irc)
dcamp: review+
Details | Diff | Splinter Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-21 09:30:16 PST
Web console assumes that it's OK to make all elements horizontally scroll together. Traditional consoles force vertical scrolling only.
So GCLI creates a paragraph of text expecting that the console will keep it horizontally constrained, but the console lets is overflow.

On the other hand there are types of console output (more than URLs) that need some sort of special 'wide' treatment.

There is probably a compromise where we elide the URLs in a smart way. (IIRC we were originally up against a bug that's since been fixed?)
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-12-12 05:06:58 PST
Created attachment 580882 [details] [diff] [review]
upload 1

Hacky fix which uses JS to adjust the size of the GCLI outputs, but leaves the others alone.

It is expected that there will be better long term fixes than this one.
Comment 2 Dave Camp (:dcamp) 2011-12-15 14:28:53 PST
Comment on attachment 580882 [details] [diff] [review]
upload 1

r+ with a clarification of the 'a.k.a. otherWidth = 123' comment.
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-01-09 07:50:08 PST
https://tbpl.mozilla.org/?tree=Fx-Team&rev=9ea2996a1f3c
Comment 4 Tim Taubert [:ttaubert] 2012-01-10 14:49:14 PST
https://hg.mozilla.org/mozilla-central/rev/a64fb47161e7

Note You need to log in before you can comment on or make changes to this bug.