Mail's eMail attachment cannot be moved to folders

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: alainch, Unassigned)

Tracking

8 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

My server's antiSpam flag as Spam the offending emails and put it as an "attached .eml"
As it often make mistake it was easy to take the attachment and put it  directly into the inbox.

With this silly version:
I cant anymore interact with the attached email

cannot move it to any folder



Expected results:

Direct interacton with attached emails
(Reporter)

Updated

7 years ago
Summary: Mail's Mail attachment cannot be moved to folders → Mail's eMail attachment cannot be moved to folders

Comment 1

7 years ago
Are you saying that you used to be able to do this before? "With this silly version" vaguely implies that, but it's extremely unclear.

I think squib landed a fix recently to allow you to copy attached e-mails into a folder, but that's only in nightly builds, and won't ship for 10-14 weeks or so (I don't remember when it landed).
(Reporter)

Comment 2

7 years ago
GOTCHA ! ! !

Sorry for Bugging you ...
It was the Conversation extension that messed up all my TB !!!

1) lost the headers in the preview pane
2) lost the ability to manage the attachments
3) had hidden some important messages putting them UNDER the originator 

TRASHED IT !

Now I hope I will have the plain and usual safe TB!!

AlainCh ( Thanks !
(Reporter)

Comment 3

7 years ago
Yes I'm able to do it (again).

At the bottom of the preview's pane there is a bar with all the attachments.

Just click and move the attachment to a mail-folder .. it work ! ( if it's an .eml)
(Reporter)

Comment 4

7 years ago
Wrong!
I cannot do it anymore.

There was TWO way to do it
1) click and drag
2) Open it then "move to folder"

Both way are not working anymore

:-(

Comment 5

7 years ago
(In reply to David :Bienvenu from comment #1)
> Are you saying that you used to be able to do this before? "With this silly
> version" vaguely implies that, but it's extremely unclear.

I really doubt this ever worked, unless I'm misunderstanding what comment 0 is about, since we have a 5-digit bug open on this issue: bug 11013. (Also, we don't have anything in the backend to support this[1]; we can only copy messages in mail-folders and .eml's on the filesystem.)

> I think squib landed a fix recently to allow you to copy attached e-mails
> into a folder, but that's only in nightly builds, and won't ship for 10-14
> weeks or so (I don't remember when it landed).

That was just for .eml's on the filesystem. I specifically excluded attached messages since we're missing the aforementioned backend function. I'd like to remedy that soon-ish, though.

[1] http://mxr.mozilla.org/comm-central/source/mailnews/base/public/nsIMsgCopyService.idl

Comment 6

7 years ago
I'm wondering if the reporter has an extension installed that does this, or if by folder, he means file system folder, and not mail folder, and he's using save as.
(Reporter)

Comment 7

7 years ago
Mail-folders

Sorry if I generate some confusion on that.

It's now more or less 3 years i'm using TB  and being Aruba'spam system dealing with SPAM the same way.. for at leat 5 years :-)

.. I get an Email saying on the Object ***SPAM***
I filter it to a folder.
I check every day the Spam Folder and do look in the preview without opening the attachments for SPAM mistakes.

When I found the attached email correct I just dragged it ...
If not sure just opened it and ( >messages>move to folder> )

I'm just surprized that that's not working anymore.
Becomming older means I'm loosing contact with things and often I forget... but 3 years is a long times  and many emails recovered from attachment !

Comment 8

7 years ago
I have the same issue with Thunderbird 8, I can no longer import attached messages into the current folder. I frequently use this feature to unwrap forwarded mail.

I found out that this feature is actually provided by the ImportExportTools extension:

https://addons.mozilla.org/en-us/thunderbird/addon/importexporttools

That would be great if it was possible to drag an attached message directly into a folder without using an extension.
(Reporter)

Comment 9

7 years ago
OOOH  ! ! !

That's Great. It's the response to the mystery attachment.

I had the ImP/Exp toll add-on installed ...and I have uninstalled it !

That's the reason I'm not able anymore to move Email's email attachment directly to a folder !!

Thanks Emanuel for sharing it !
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.