Compatibility update not applied for default-to-compatible addon's that don't meet min compat version in install.rdf

RESOLVED DUPLICATE of bug 527141

Status

()

Toolkit
Add-ons Manager
P1
normal
RESOLVED DUPLICATE of bug 527141
6 years ago
6 years ago

People

(Reporter: Unfocused, Assigned: Unfocused)

Tracking

10 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

If an addon on AMO has in it's install.rdf a maxVersion of 3.7, it's not compatible even with strictCompatibility disabled, since 3.7 is less than the minimum compatible version. However, if AMO declares the maxVersion is actually higher than the minimum compatible version, then the add-on should get the compatibility update and it should be compatible.

If you try to install such an addon, it currently fails - claiming incompatibility. Sounds like the compatibility update isn't getting applied.

Example: https://addons.mozilla.org/en-US/firefox/addon/element-properties/
install.rdf maxVersion: 3.7a1pre
AMO maxVersion: 10.0a1
Looks like this is due to AMO not returning any updates, which means no updated compatibility info is sent either.

So, basically, due to bug 698355 not going live yet. I checked that theory with the same request going to the development site, which does return an update.

Will leave this open until bug 698355 goes live, to make sure this gets verified.
Depends on: 698355
Nope, it's also due to my misunderstanding of compatibility updates - I had assumed they always get applied, but it turns out they only get applied when AddonUpdateChecker thinks they make a difference. So it's a bug in my patch for bug 527141.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527141
You need to log in before you can comment on or make changes to this bug.